Sign in to follow this  
bhorsoft

Install 777/737 in both P3D 2.5 and 3.0?

Recommended Posts

I've bulked up my system enough that I can run Prepar3d v2.5 and v 3.1 on the same machine (though not at the same time  :fool: ).  I already installed the 777 and 737 NGX in 3.1.  Now I am trying to install in 2.5 and all I get is a dialog asking if I want to modify, repair or replace my existing installation. The different versions of P3D are installed on separate drives. The reason I want to install on both versions is I have other add-ins (mostly scenery) that only work in 2.5.  When (and if) all my add-ins catch up to 3.1 then I'll ditch the 2.5 but for now I need the older version for some flights.

 

Is there a way to install the PMDG aircraft in both versions of P3D?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The reason I want to install on both versions is I have other add-ins (mostly scenery) that only work in 2.5.

 

Which ones don't? I haven't had any scenery reject the v3 location. At worst, you just have to point it to the v3 location and manually add it to the scenery library in the sim.

 

EDIT:

Full names - first and last - in the forum, please.

Share this post


Link to post
Share on other sites

Mostly some older and more obscure locations.  Drzewiecki Design UUEE, KLGA and KEWR, LatinVFR SLVR and SKBO, I also got SAEZ, SBRJ, and LTBA from some other vendors.  

 

I was under the impression that scenery had changed some for 3.x in an attempt to make the 3.x series more "upgradable" without clobbering scenery.  I think the idea is to keep the scenery in directories separate from the P3D directories.

 

That said, I have a couple of the titles don't give me a path option on install - just FSX or P3D 2. Chatter on some of the developer forums mention issues with the 2.5 versions working in 3.x.  Most of the developers say they are working on upgrades.

 

I am guessing I can install the scenery in 2.5, copy to 3.1, and manually add.  It might work well enough.  I have tried the same thing earlier by copying some FSX airport scenery to P3D 2.5 with mixed results.

 

So, the question still stands:  Is it possible to install PMDG P3D aircraft in both 2.5 and 3.1?  I do have other aircraft that ask me at the start of the install which simulator I want to use - v1, v2 or v3.  I just want to use the PMDG because they are my favorites.  I'm still flying my old FSX on occasion because I want a good 747 to fly.

Share this post


Link to post
Share on other sites

As far as scenery goes, there is no difference between 2.5 and 3.x.

As far as separate directories, this is just a recommendation by LM to reduce complaints when they change their set up and by no means implies that legacy methods such as add-on folders no longer work.

As far as other addons, many have updated installers for P3Dv3 and those that haven't can still be installed manually. I've ran into one or two that need to see fsx.exe in the main flightsim directory. Easy:  Create a zero length file with filename fsx.exe.

 

I've not found a scenery from anyone that doesn't work in P3Dv3 and I have a few.  For example, SAEZ from TropicalSim has a new installer for v3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this