Sign in to follow this  
vc10man

CTD Using Orbx EU Scotland

Recommended Posts

Scenery: Orbx EU:Scotland

Aircraft:  Majestic Dash8 Q-400/Aerosoft AXE A319

Arrival Airport :UK2000 EGPK(Prestwick)

CTD: Faulting module:API.dll or g3d.dll

 

Can anyone kindly check if they too are getting a CTD using this scenery flying the approach to Rwy 13 at EGPK where twice in different aircraft, I have had a CTD at around 3500 ft? Yesterday I had it happen with the Aerosoft AXE 319 which I think according to EventVwr threw up a g3d.dll faulting module; and just now with the Majestic Dash8 Q400, an API.dll faulting module.

 

If someone much more knowledgeable than I has an idea what is causing this CTD, I'd be grateful. Thanks.

 

Windows 10 Pro 64-bit FSX-SE.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

What, no one in this Forum who can shed light on this? Amazed.

Share this post


Link to post

Hi Rick

So that you know you're not being ignored......I can't help with any advice on what might be causing your CTD but I've just flown the same approach successfully in several aircraft: RealAir Duke Turbine V2, iFly 737, Aerosoft Twin Otter Extended, JF A320.

 

I'm using ORBX Scotland scenery too, although I don't have UK2000 Prestwick (I prefer UK2000 Glasgow!)

 

Good luck with this one - CTD is so annoying when it happens.

 

Rupert

Share this post


Link to post

what is your VAS usage? running out of memory is fairly common with high settings, orbx region, and addon airports combined. maybe try turning down your autogen setting to 'normal' or even 'sparse' and see if that solves it.

 

similar to rupert i am unable to test your specific example since i don't have that particular airport. i fly into uk2000 egnx and the england scenery pretty often without troubles but i do have fairly conservative autogen and traffic settings since my machine is a bit old.

 

cheers

-andy crosby

Share this post


Link to post

Hi Andy and Rupert

 

Thanks, gents, for your most welcome inputs. Appreciated.

 

Perhaps you guys can shed more light. Late last night, I went to the FTX Central 2 and saw that I needed 4 Service Packs for EU:England, and 2 SPs for EU:Scotland. I got the SPs, installed them, then today re-run the same flight which I had saved, and this time, lo and behold, no CTD.

 

So, was it the fact that in the first instance there was a clash with UK2000's EGPK and Orbx EU:Scotland, which was then resolved in the second instance by applying those SPs?

 

And one further question, when I just had the UK2000 EGPK(Prestwick) airport, all the aprons were fairly light and discernible in colour. Now, after applying those Orbx EU:Scotland SPs, the aprons all look black I can hardly tell is my Majestic 8-Q400 is on the tarmac.

Share this post


Link to post

 

 

So, was it the fact that in the first instance there was a clash with UK2000's EGPK and Orbx EU:Scotland, which was then resolved in the second instance by applying those SPs?

 

And one further question, when I just had the UK2000 EGPK(Prestwick) airport, all the aprons were fairly light and discernible in colour. Now, after applying those Orbx EU:Scotland SPs, the aprons all look black I can hardly tell is my Majestic 8-Q400 is on the tarmac.

 

well.. maybe it was a clash, maybe just something amiss with the earlier version of the orbx files. hard to say for sure..

 

not sure about the other issue. did you ensure that the airport layers are above the orbx stuff in your scenery library? the order might matter in this case.

 

a while back i had some odd texture issues with my uk regions that i fixed by rebuilding the terrain.cfg file which was pretty easy to do, there are details outlined in the orbx support forums on that (search for 'texture morphing' bug on their forums.) hard to say if that is your problem either. maybe you could post a screenshot.

 

you might have better luck at the orbx forums or the uk2000 ones as it may be more likely to find someone using the same combination with both the region and that particular airport.. prestwick is on my list of ones i want to pick up eventually but i already blew my budget during the holidays ;)

 

good luck

cheers

-andy crosby

Share this post


Link to post

did you ensure that the airport layers are above the orbx stuff in your scenery library? the order might matter in this case.

Andy, thanks for taking time to respond.

 

That's the bit I have no idea how to check/ rectify.

 

After a while fiddling around, changing parking positions, I finally found a non-black surface to park the Dash8 on. I had set the tarmac theme via Orbx FTX.

 

Thanks for the suggestion of posting in the Orbx or UK2000 sceneries. I like Gary's output and being a British developer, I like to support his products. I have a range of his Xtreme Airports,and last sale just before Xmas had picked up a hatful.

Share this post


Link to post

Rick

The order in your scenery library is worth looking at. I have UK2000 airports at the very top and above the UK2000 Common Library (which must be below UK2000 airports AFAIK). I've then got all my ORBX FTX, followed by OLC.

 

I hope I'm not stating the obvious but the way to check or adjust the scenery order is in FSX:SE / Settings / Scenery Library. I would recommend that you check the UK2000 Common Library is definitely below the airports and that your ORBX is above the default FSX layers.

 

...and yes - Gary's work is fantastic and well worth the investment.

 

Hope this helps.

Rupert

Share this post


Link to post

Hi Rupert

 

You ace!

 

That's precisely where my Scenery order was out of sync. Have rectified it as per your suggestion.

 

Fingers crossed!

 

Thanks a bunch for your help.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this