Sign in to follow this  
antonvs

CTD on exit with possible causes

Recommended Posts

Hi, I wonder if some of the guru's in this community could help me analyse the attached minidump error files in the hope of tracking down a problem that has arisen whereby FSX:SE now crashes on exit (CTD) after any flight with the exception of a short hop in the default Trike.  
 
Links to minidump error reports. Two dumps happened during the CTD process.
 
 
Background:
FSX:SE, Win10, i7 64bit, 16Gb RAM PC, DX10, Steve's fixer, ASN, FTX GLOBAL, Pilot's FSGlobal 2014 mesh.
 
I have had my GTN750 gauge running successfully for a few weeks. Then Successfully installed into my Flysimware Learjet 35A. Not content, I then tried to install a 2nd 750 into the same plane using your installer. 

Result. FSX CTD on first load. 2nd try I got an err msg "FSUIPC not supported". I answered "yes" to continue anyway. FSX then failed to load. On a 3rd try, I said "No" to FSUIPC and FSX ran after I selected "yes" in controllers for Joystick. The LJ35A ran ok with a single 750 gauge. 
 
In addition to having no use of FSUIPC I also find that any flight (even a short taxi) results in FSX CTD on exit (every time). If I Start FSX and select aircraft, location etc. but don't start a flight, I can exit ok without a CTD. This happens when loading my RA Legacy V2 as well.
 
I have yet to try a reinstall of either the GTN750 or FSUIPC. I have checked my Logbook.bin file and it appears to be ok as it reads in LogEdit. I have also run FSX without loading ASN (but I have not reinstalled ASN)
 
Any help or suggestions would be greatly appreciated.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

A progress report.

 

I can confirm that my original error was to inadvertently use Flight1 GTN config tool on the wrong plane. I had tried adding a second gtn750 to the Flysimware Learjet 35A (GNS) version instead of the (GTN) version (in a senior moment).

 

So far to try and get my system back to normal I have done the following:

 

1. Updated drivers via Driver Blaster

2. Tried replacing FSX.EXE, g2d.dll and g3d.dll from a backup

3. UN-installed the GTN 750 gauges

4. Un-installed FSUIPC4 and reinstalled

5. Un-installed Flysimware Learjet 35A

 

Rebooted, but with all the original problem add-ons removed FSUIPC4 is still reported by FSX:SE as having a problem in module FSUIPC4.dll

 

Flight1 via the Simconnect forum say it's not their problem. I'm yet to hear back from FWS so my options are thinning. I'm hoping I don't have to face a full rebuild as the Sim will run ok with any aircraft (Inc add-ons) as long as I don't load a GTN version and the Sim runs very well, even for long periods and will shut down ok and save the flight to the logbook. But with the cavert is that I can't use FSUIPC4. The last rebuild I did took a month or so to complete so I naturally hope to avoid this option.

 

Any help please would be very appreciated.

Share this post


Link to post
Share on other sites

You may have corrupted your fsx installation by replacing the fsx.exe, g2d and g3d.dll's.  I mean, this is FSX-SE that you have loaded and you just cannot do that to FSX-SE (or FSX) as the FSX.exe was changed when it was upgraded to SP1 and SP2 (and Acceleration).

 

You have identified the problem - the FSUIPC.dll module.  Have you installed the latest update?  The version I have is 4.949h dated 3/2/2016.

 

If you are networked with several computers at your house, then simconnect could be a problem but, if you just have one computer, simconnect is NOT the issue.

 

You can try to reinstall FSX-SE.  You will probably be told it is already installed and asked if you want to do a repair.  Select that option.  It will replace your FSX.cfg and scenery.cfg (but not your dll.xml as that is not a default file).  So, if you want to return your fsx-se.cfg and scenery.cfg, you will want to back them up.

 

The best solution for any crash is to return the sim to the default.  That requires moving the FSX-SE, Scenery.cfg, and dll.xml to a temporary folder.  Run FSX-SE.  Runs okay?  Then move the scenery.cfg back first.  Runs okay?  Then move the fsx-se.cfg back.  You already know the fsuipc.dll will not load properly so you either update that or disable it from loading int he dll.xml. 

 

Hope this helps.

 

Best regards,

Share this post


Link to post
Share on other sites

Hi Jim and thanks for coming on board. The three files I replaced were recent backup (prior to this current mishap) from the live install and that process worked ok, but did not solve the problem, just proved that fsx:se is ok.

 

I will try installing the latest version of FSUIPC4 but the version I have (probably 4.9.1) was running fine and I have a gut feeling it is something in FSX:SE that is corrupt. Just hesitant to run a repair at this stage as I mentioned, it runs so well otherwise.

 

Anyway one step at a time.

Share this post


Link to post
Share on other sites

So hear is the good news! All is well. Here are the two things I did that solved the problem, I offer this in case it helps anyone else.

 
1. Ran Steam "Verify integrity of installed files" from the Steam client under properties of FSX
This found 4181 files that failed the integrity test.
 
2. Reinstalled the latest version (4.949h) of FSUIPC4
 
These two things done cleared the CTD's and all other issues.
I was then able to reinstall all the files that I had removed and now back to flying with colors.
 
Thanks again Jim for your help. And hope it helps someone else.

Share this post


Link to post
Share on other sites

Good news!  Thanks for letting us know how you fixed your problem.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this