Sign in to follow this  
zool

Wilco climb rate

Recommended Posts

Hi folks 

 

i have wilco airbus A330-300 , the problem is aircraft climbing too fast 

last flight I had 5800fpm ! 

 

any help 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

What specifically were the circumstances?  I can make almost any aircraft climb that fast ..... for awhile.

Share this post


Link to post
Share on other sites

Wilco Airbus models have a completely wrong performance model. It's just the way they're made.

 

Aerosoft improves quite a lot (while still being wrong), but unfortunately there's no A330 yet.

Share this post


Link to post
Share on other sites

What specifically were the circumstances?  I can make almost any aircraft climb that fast ..... for awhile.

 it’s a normal climb , after takeoff shifting the throttle back to CLB mod

and when the speed reaches 250kts it starts climbing by very high fpm 

Share this post


Link to post
Share on other sites

You should use the Wilco configuration manager before every flight:

Having entered all the details into config manager, keep it open while FS launches and you have the A330 panel onscreen.

Program the FMC with ALL the required info such as ZFW etc. from the configuration manager - the more info you give it, the better it flies (there is nothing wrong with the performance model).

Share this post


Link to post
Share on other sites

(there is nothing wrong with the performance model).

 

Yes, except everything.

 

You can fully load the 330 with PAX and fuel and it'll climb to FL410 at 2000ft/min. If this isn't wrong, we're flying an F-16 and nobody told me.

Share this post


Link to post
Share on other sites

Zool

 

Contact me via PM.

I have a set of FD that are correct.

 

Trevor

Share this post


Link to post
Share on other sites

Yes, except everything.

 

You can fully load the 330 with PAX and fuel and it'll climb to FL410 at 2000ft/min. If this isn't wrong, we're flying an F-16 and nobody told me.

 

I am genuinely surprised by this, though I notice you have a Prepar3d banner in your signature - I only use FS2004.

 

 

Zool

 

Contact me via PM.

I have a set of FD that are correct.

 

Trevor

 

Trevor, thanks for reminding me that I have applied every tweak and mod available to the Wilco Airbus series years ago, and FD's were probably among them - I've had them for so long now I honestly can't remember!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this