Sign in to follow this  
GoingForGold

Audio Routing

Recommended Posts

Hi all,

 

I am a long reader of the forums here, but I did not have a problem I couldn't solve with the information already on here, until now.

 

I use FS2Crew with my Aerosoft Airbus Xs and I love it. However, to make it work, I need to set the headset as Default Device in Windows. It is not enough to define the headsets microphone as Default Recording Device, FS2Crew will not be listening.

 

Unfortunately, defining the headset as Default Device means, that most audio is routed via the headset. In P3D v3, there is an option to route audio to another device, which I did (my speakers). However, all Aerosoft specific sounds (like the ventilation in the cockpit), as well as FS2Crew sounds (i.e. the F/O) are only coming out of the headset. This makes it very tricky to listen to both sources at the same time and is also not very realistic.

 

Is there any workaround to this?

 

Thank you!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You could try "VirtualAudioCable" or "What You Hear" depending on your sound hardware - these are able to internally reroute audio streams.

Share this post


Link to post
Share on other sites

 

 


However, to make it work, I need to set the headset as Default Device in Windows.

 

Why do you need to do that?

 

For 99 percent of users, their speakers are the default playback device in Windows.

 

Then if you want most of the FO audio to go through your headset, you'd set the Audio device associated with your headset in the FS2Crew Config Section, and then press HS on the FS2Crew Main Panel.

 

Cheers,

Share this post


Link to post
Share on other sites

Thanks, Lorby_SI for that idea. I think I figured that Virtual Audio Cable does not help, but What you hear could, maybe.

 

byork, I already talked to you for a support case. I tested it now multiple times, on my Win8.1 machine, I have to set the headset as Default Devic, otherwise it is not going to work. I dont find it logical, but it is the way it is.

Is the setting in the CFG menu about where to playback the sounds? Or is there more behind it?

Share this post


Link to post
Share on other sites

 

 


Is the setting in the CFG menu about where to playback the sounds? Or is there more behind it?

 

Correct, it's in the 'Audio Setup' field.

 

Select the audio device you want the FO to use for checklists.

 

Then press HS on the Main Panel.

 

http://www.support.fs2crew.com/help/manuals/#pageid=configuration_panel_overview1

 

 

As mentioned, most people would select their headset for the audio device.

 

 

But your setup seems different  :smile:

 

Cheers,

Share this post


Link to post
Share on other sites

Yes, perfect would be if I could hear the F/O on speakers and headset and all other sounds just on the speakers. But I think as long as I'm not able to set the speaker as my Default Device (due to FS2Crew not working with this setting), the Aerosoft specific sounds will still be going through the headset.

Share this post


Link to post
Share on other sites

 


It is not enough to define the headsets microphone as Default Recording Device, FS2Crew will not be listening.

 

Are you using two computers over a network or something?

 

Cheers,

Share this post


Link to post
Share on other sites

This somehow sounds like your "Speakers" are actually their own sound device - are they connected via USB? If that is the case, then it is completely logical that you have trouble using them in this setup. Virtual Audio Cable can help you, when you reroute the audio stream from FS2Crew to your preferred device. But I have to admit, I never tried it myself, I am using non-virtual, real audio cables - I have two different soundcards and both outputs feed into an external mixer with headphone amplifier. But once upon a time I had a high quality soundcard from EMU that had an application similar to the VAC, and the internal rerouting worked pretty well.

Share this post


Link to post
Share on other sites

byork, no, just one.

 

Lorby_SI, that's an interesting question. First, no, they are not a sound device themselves. However, the mainboard itself has multiple outputs. So I can choose via software whether I want to output sound via the back or front connectors. So the speaker are kind of a device on their own, as the mainboard offers multiple outputs.

My doubts with your proposed software solutions would be that I would need to choose the VAC as the new Default Device, which would in turn (I guess) create the problem that the headset is not anymore the Default Device.

Share this post


Link to post
Share on other sites

Hello there,

 

I would like to bring this topic up again. I recently updated to Win10 and hoped that this issue might be solved, but it isn't.

 

Please let me quickly recap the problem:

 

Aerosoft Airbus has its own sounds (humming of the A/C, some clicks etc), which do not come from the sim. I can specifically route sim-sounds to a sound output (p3d setting), but the Aerosoft sounds go to the "default device" selected in the windows settings. So in order to have all sounds coming from the speakers, I select the speakers as the default device and my headset as the default communication device, the microphone (of the headset) as the default recording device. This works perfectly with speech recognition in windows. There is even a setting which forces this microphone to be the input for speech recognition, no matter what the default recording device is.

 

However, with this setup, FS2crew will not recognize my speech at all. There is no green bar at the top where I can read what I said. As soon as I switch the default device to the headset (note: the default <output> device), FS2crew works perfectly. However, this means that I have the Aerosoft sounds on the headset.

 

I would really like to have all sounds on the speakers and just use the microphone of the headset.

 

There were some proposed solutions with virtual audio cables involved. The reason that these solutions wont work that I need to select the headset as the default device. I can not route any audio to the virtual audio cable, as this would have the same effect.

 

Maybe, this can give a hint to the solution, as this could be related: The FS2Crew settings allow me to chose an output device. However, no matter what I chose, the sound come always from the default device. So this looks to me as FS2crew has some issues with handling audio on my computer.

 

Any hints appreciated :smile:

Share this post


Link to post
Share on other sites

You have a complex audio setup.

 

Please send me a Support Ticket via www.fs2crew.com

 

I can try to help you via a remote desktop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this