Sign in to follow this  
Manschy

DX10: Aircraft won't appear at special scenery....

Recommended Posts

Hi everybody,

first of all I have to say, I can't live without Steve's Scenery fixer - one of the best improvements for FSX ever. Thank's again, Steve!!!
From the very beginning, I use FSXA with DX10 preview and Steve's Scenery Fixer. I have to say, ALL AI packages I have installed, work fine with shadows and enabled FSX DX10 preview mode. Well, except for one special instance:
The NBAI Phantom F-4F package won't appear at the FSX german air base Hopsten correctly! It is strange, because the Phanties work correctly at all other airbases. Here some shots for clarification:

Fine with shadows at RAF Coningsby:
HOPSTEN_F4f_CONINGSBY_zpsuwsi5ktf.jpg

Fine at RAF Gutersloh:
HOPSTEN_F4f_ETUO_zpsssjbjwsn.jpg

Fine at RAF Wattisham:
HOPSTEN_F4f_WATTISHAM_zpsxey4aohq.jpg

And here at Hopsten, the devil is in the detail as follows:
Especially only at one and the same place (a north side apron), some of the NBAI Phanties appear correctly (fine with shadows beside some other AI, here a Tornado):
Hopsten_F4_WITH_SHADOWS_zpsbwxuimyn.jpg

But anywhere else, no Phantoms!
Okay, now I disable the 'shadows on aircraft mode' in FSX, suddenly the aircraft appear correctly everywhere!!!

Now my questions:
Why does this happen in that way?
Shouldn't it show either all AI aircraft here or none at all?
Due to this behaviour, in my opinion it must be a scenery issue, neither an aircraft nor an options issue, because the NBAI phantoms work fine on other airbases....
Each help is much appreciated!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It's an incompatibility between some sceneries that use the old sdk and aircraft that use the old sdk, it's not a dx10 issue insofar as I know - it happens the same in dx9.

 

I understand it's connected with some old scasm code that if the scenery uses then it impacts ai aircraft if they cast shadows on the ground.

Share this post


Link to post
Share on other sites

Thank you Steve. I didn't assume it is a DX10 issue - but strange indeed, that some of the packages aircraft appear, most don't. So if it is a code mistake, there shouldn't appear nor other AI jet packages. What a challange...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this