MindYerBeak

windows update and : error creating child window ...P3Dv3 ?

Recommended Posts

Today i ran windows update. Right after rebooting and starting the sim  I got the "error creating child window" error

 

Not sure what is going on .I ran a search but I'm not any wiser. Is  any any update causing this that you know of ?

 

All info/help/tips appreciated

 

Thanks

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

This appears to be an issue if you are on the Windows Insider Fast Ring and getting the new Redstone 3 builds which as of right now is Build 16188. From what I have been able to determine, the problem looks like it is caused by Microsoft's introduction of the new OneCore architecture. I will admit that most of this is conjecture based on the research I have done to try to resolve the issue. What is frustrating is that every once in a while P3D runs normally. But, more often than not, it doesn't. I have tried disabling all addons and then enabling them one at a time but the results of those tests were inconsistent. I wish I could find out what child window was trying to be opened but, so far, no luck.

For what it's worth, I don't run with a lot of addons. I run:

VRS Superbug with TacPack aircraft of choice
MegaSceneryEarth and Bluesky photoreal scenery
ActiveSky 2016 weather
Ultimate Traffic Live
FSUIPC (registered version)

Mike

 

Windows 10 Pro Insider Preview 64-bit Build 16188.rs_prerelease.170430-1928
SABERTOOTH Z97 MARK 1 (SOCKET 1150)
Intel Core i7 4790K @ 4.00GHz (Liquid cooled)
32.0GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
3071MB NVIDIA GeForce GTX 780

Not top of the line, but no slouch, either.

Share this post


Link to post

That's what I get for responding to a post I found with Google without looking at the original posting date.

My apologies for replying to an old topic.

Mike

 

Share this post


Link to post

hahahaha, Mike,

It's happening as of last week to the new stuff too. lol/  Wish I had a clue what was causing it.  I been trying to workaround this for the last 2 weeks. 

:(

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now