Sign in to follow this  
Raven9000

X-Plane shadows are Horrible, wth?

Recommended Posts

 

So I'm starting to build up my x-plane install, etc. and I've run into an issue that I don't quite know how to fix...

 

It's concerning shadows. Shadows inside the cockpit, and also external shadows, for example those of my aircraft against the runway or parts of the aircraft against other parts of the fuselage.

 

The level of jaggedness they have is horrendous, and really take away from the immersion factor.

 

I have seen videos/screenshots of other folks where these are quite smooth, but I haven't found a way to change the settings on my setup to come even remotely close to that.

 

 

Just to be clear, this is not a "general" issue with the settings and rendering options. EVERYTHING else (the aircrafts themselves, scenery, instruments, etc.) are just great and as smooth as you set the AA options to. It is just with this element, the shadows, where I have problems.

 

Here are some sample screenshots:

 

 

Bell407_4.jpg

 

Bell407_5.jpg

 

Bell407_6.jpg

 

Bell407_7.jpg

 

 

Does anyone have any idea/clue as to what could be wrong/what I could try?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

X-Plane10 cockpit shadows have always been an issue as far as I know, and I just think of it as one of those X-Plane things. I just turn them off.

Share this post


Link to post
Share on other sites

Can you provide a screenshot of your rendering settings?

Share this post


Link to post
Share on other sites

Try this, if you're using an NVidia card.

 

1) Go into the NVida Control Panel, Manage 3D settings

2) Set up a Program Settings profile for xplane.exe if you don't already have one.

3) Under "Antialiasing - FXAA" set that to On. 

 

For some reason, forcing FXAA in the nVidia panel cleans up a lot of aliasing artifacts no matter what I set in X-Plane's own settings. My current settings are HDR On, HDR Anti-Aliasing 2XSSAA + FXAA, with FXAA forced on in the nVidia control panel. Here's what it looks like for cockpit shadows and external shadows. Still a bit of aliasing if you look closely, but not nearly as bad as your screen shots:

 

http://ptjams.com/mb/img/planes/Car_C208B_v10_1-shadows-01.jpg

 

http://ptjams.com/mb/img/planes/Car_C208B_v10_1-shadows-02.jpg

 

 

Share this post


Link to post
Share on other sites

It's concerning shadows. Shadows inside the cockpit, and also external shadows, for example those of my aircraft against the runway or parts of the aircraft against other parts of the fuselage.

 

The level of jaggedness they have is horrendous, and really take away from the immersion factor.

 

Does anyone have any idea/clue as to what could be wrong/what I could try?

 

Go to the rendering settings, you'll find a setting named "shadow detail":

 

nWHCEGX.jpg

 

"Global (low)" will give you aircraft and scenery shadows, but very jagged lines:

 

uvJJDxz.jpg

 

The shadows will become less jagged the higher you go, but it will require more GPU power (FPS may decrease). Here it is at the max setting of "Global (melt your GPU)":

 

iJgcb1M.jpg

 

BUT! You can select the lower setting called "3d on aircraft". You'll lose scenery shadows, but you'll have very sharp aircraft shadows and probably higher FPS:

 

0rKVOW2.jpg

  • Upvote 1

Share this post


Link to post
Share on other sites

There is no real fix for the jaggies in the VC -  they are pretty much broken.

 

Strangely the same issue exists in P3D as well.

 

I suspect it has to do with AA not getting applied to shadows so the jaggies you see are shadows from the edges of square pixels on the edges of the cockpit, they are stretched and distorted but that's just because of the angle of the light source.

Share this post


Link to post
Share on other sites

Can you provide a screenshot of your rendering settings?

 

Yes, here they are:

 

render.png

 

 

Go to the rendering settings, you'll find a setting named "shadow detail":

 

 

"Global (low)" will give you aircraft and scenery shadows, but very jagged lines:

 

 

The shadows will become less jagged the higher you go, but it will require more GPU power (FPS may decrease). Here it is at the max setting of "Global (melt your GPU)":

 

 

BUT! You can select the lower setting called "3d on aircraft". You'll lose scenery shadows, but you'll have very sharp aircraft shadows and probably higher FPS:

Thanks, I tried that but while it seems to improve the external shadow of the plane (and I say seems because if you zoom up a bit you can see it's bad anyway), it does nothing to solve the VC ones, which are what you see most of the time anyway. Here are two shots with the setting changed to what you told me:

 

Bell407_8.jpg

 

Bell407_9.jpg

 

 

 

There is no real fix for the jaggies in the VC -  they are pretty much broken.

 

Strangely the same issue exists in P3D as well.

 

I suspect it has to do with AA not getting applied to shadows so the jaggies you see are shadows from the edges of square pixels on the edges of the cockpit, they are stretched and distorted but that's just because of the angle of the light source.

I think I'm sadly realizing that...

 

However this does not happen in P3D at all... (and if it's does, I'm guessing you have some sort of super microscopic vision, as I definitely cannot see this at all...)

Share this post


Link to post
Share on other sites

Try this, if you're using an NVidia card.

 

1) Go into the NVida Control Panel, Manage 3D settings

2) Set up a Program Settings profile for xplane.exe if you don't already have one.

3) Under "Antialiasing - FXAA" set that to On. 

 

For some reason, forcing FXAA in the nVidia panel cleans up a lot of aliasing artifacts no matter what I set in X-Plane's own settings. My current settings are HDR On, HDR Anti-Aliasing 2XSSAA + FXAA, with FXAA forced on in the nVidia control panel. Here's what it looks like for cockpit shadows and external shadows. Still a bit of aliasing if you look closely, but not nearly as bad as your screen shots:

 

http://ptjams.com/mb/img/planes/Car_C208B_v10_1-shadows-01.jpg

 

http://ptjams.com/mb/img/planes/Car_C208B_v10_1-shadows-02.jpg

Thanks for the suggestion, but something else must be wrong on my system, or it's not taking it, as I just tried and see no change. The ones you show are something I definitely would be OK with.

 

Would you mind sharing your render settings, and you Nvidia control panel ones too? (and Nvidia Inspector if you use it).

 

Thanks.

Share this post


Link to post
Share on other sites

Clearly you can see it in P3D too:

 

https://onedrive.live.com/redir?resid=1E89A24EA589A628!479&authkey=!AMsNuniNYMLhJYw&v=3&ithint=photo%2cjpg

 

and another:

 

https://onedrive.live.com/redir?resid=1E89A24EA589A628!481&authkey=!AFgRLlJU6f8INrM&v=3&ithint=photo%2cjpg

 

No amount of tweaking or tuning will make it go away because (I think) the shadows are done at the same time as AA in the rendering pipeline for both sims.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks, I tried that but while it seems to improve the external shadow of the plane (and I say seems because if you zoom up a bit you can see it's bad anyway), it does nothing to solve the VC ones, which are what you see most of the time anyway. Here are two shots with the setting changed to what you told me:

 

Try using this tweaked settings.txt file then:

 

http://wikisend.com/download/417818/settings.txt

 

You must overwrite the original "settings.txt" located in the "Resources" X-Plane folder. Backup the original (although, even if you don't back it up, you can revert back to the original file if you run the X-Plane updater. It will detect a modified "settings.txt" and will ask whether you want to restore it to the original).

 

Here are my results (original vs modified):

 

5AOTgYt.jpg

 

wPeE5DS.jpg

 

5j3iLvl.jpg

 

wJDaGer.jpg

Share this post


Link to post
Share on other sites

Thanks for the suggestion, but something else must be wrong on my system, or it's not taking it, as I just tried and see no change. The ones you show are something I definitely would be OK with.

 

Would you mind sharing your render settings, and you Nvidia control panel ones too? (and Nvidia Inspector if you use it).

 

Sure, here are my render settings for the two Caravan screenshots above (and FXAA forced on in Nvidia control panel):

 

Settings1.gif

Share this post


Link to post
Share on other sites

Thanks to both, will try to play around with these and see if I can improve something...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this