Sign in to follow this  
colko11

Problems with the PMDG 737-8900 ngx

Recommended Posts

Dear helper,

Yesterday (7th of june) I purchased the PMDG 737-8900 (boxed edition) but I have experienced some problems today. NOTE: I haven’t installed any of the service packs yet.

  • After installation (I ran as administrator) my FSX keeps crashing every time I end my flight. For some reason it says ‘’fatal error occurred’’ or it shuts down even without saying that. Sometimes I get this error as well in game. Before I installed PMDG I didn’t have any problems with crashes or so.
  • I also experience some problems with the planes when I start a flight. When the game is loaded my planes sometimes look like this: http://imgur.com/G1WE4QZ  I can’t press any button or switch and all the screen are black. As you can see the textures of the panels are messed up as well. I experience this a lot when I play multiplayer with the 737-900, but sometimes as well in free flight.

Now, these problems are annoying me because I haven’t done a proper flight yet with my new airplane and I already have a lot of troubles. To be clear I don’t have any addons, AI, textures, terrain mesh, airports or any other airplanes beside the PMDG 737 and the default airplanes. Shortly, my FSX is clean.

I hope somebody is able to explain to me what is going wrong and has a solution. I thank you for your efforts,

Colko11

 

My computer specs:

I5-4570

Radeon R9 270x

4GB RAM

Windows 10 64bit

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


After installation (I ran as administrator) my FSX keeps crashing every time I end my flight. For some reason it says ‘’fatal error occurred’’ or it shuts down even without saying that. Sometimes I get this error as well in game. Before I installed PMDG I didn’t have any problems with crashes or so.

 

There's a known issue where the sim will crash is FSX is exited using "End Flight," or "CTRL + C." Instead, use the X at the top right of the screen (in windowed mode) or "ALT+F4."

 

 

 


I also experience some problems with the planes when I start a flight. When the game is loaded my planes sometimes look like this: http://imgur.com/G1WE4QZ  I can’t press any button or switch and all the screen are black. As you can see the textures of the panels are messed up as well. I experience this a lot when I play multiplayer with the 737-900, but sometimes as well in free flight.

 

What is the default aircraft in your simulator? In other words, what is the aircraft that shows up as soon as you start the sim?

 

 

 


Colko11

 

Welcome to the forum. Full names - first and last - are required to be placed in your posts.

Share this post


Link to post
Share on other sites

Dear sir,

 

Thank you for your quick response!

 

I'm going to try ALT F4 in a minute to see if it works!

 

With default aircraft I mean the 737-800, the 747-400 and on and on. When I start up FSX the ultralight shows up. 

 

And, I will change my name in a few minutes as well!

 

Thank you,

 

collin

Share this post


Link to post
Share on other sites

 

 


I'm going to try ALT F4 in a minute to see if it works!

 

Let us know.

 

 

 


With default aircraft I mean the 737-800, the 747-400 and on and on. When I start up FSX the ultralight shows up. 

 

Okay. When this happens, have you changed from one livery to another?

 

 

 


collin

 

Thanks for the adjustment, however, the requirement is first and last, like mine, below:

Share this post


Link to post
Share on other sites

Okay, quick update!

 

I just started a flight and used the ALT F4 option. Unfortunately this option did not work and FSX shut down immediatly. 

I've have installed the KLM and Delta livery of the PMDG (I think you mean this) but sometimes it still has the same weird textures.

 

Thanks,

 

Collin Meerman 

Share this post


Link to post
Share on other sites

 

 


I just started a flight and used the ALT F4 option. Unfortunately this option did not work and FSX shut down immediatly. 

 

The whole point of ALT+F4 is to quit a program. Did the program crash, or did it exit cleanly? In the end, the result is really the same, honestly.

 

 

 


I've have installed the KLM and Delta livery of the PMDG (I think you mean this) but sometimes it still has the same weird textures.

 

My question was asking the following:

When you see the weird issues, have you changed from one livery to another? As an example:

You loaded the Delta livery and then thought "you know, I really meant to load the KLM livery," and loaded the KLM livery.

Share this post


Link to post
Share on other sites

Hmm.. well.. FSX shut down cleanly I think, but I would like an option to get back to the menu without crashing!

 

Well.. If I load in a flight and I want to change my plane, I have to end the flight, FSX crashes. So, the strange textures always appear with the first plane I load in. If you want more pictures please tell me... I can make some more but I think you what's wrong with it.

 

Thanks,

 

Collin Meerman

Share this post


Link to post
Share on other sites

Hmm.. well.. FSX shut down cleanly I think, but I would like an option to get back to the menu without crashing!

 

What are you trying to accomplish. The flight is over, no?

Well.. If I load in a flight and I want to change my plane, I have to end the flight, FSX crashes. So, the strange textures always appear with the first plane I load in. If you want more pictures please tell me... I can make some more but I think you what's wrong with it.

 

If you need to change from one of our planes to another, exit the sim first.

Share this post


Link to post
Share on other sites

 

 


Yesterday (7th of june) I purchased the PMDG 737-8900 (boxed edition) but I have experienced some problems today. NOTE: I haven’t installed any of the service packs yet.

 

Hi, Collin,

 

Just to clarify, since you didn't say where you bought the boxed version, what version do you have (you might have purchased an older  boxed version somewhere)?  You can check in the PMDG Op Center in Start>All Programs>PMDG Simulations... in there you will find the PMDG Op Center.  You can also look in ...FSX/Sim Objects PMDG 737-800NGX folder.  In that folder open the aircraft.cfg file with Notepad (being careful not to edit it!).  The version should be at the top of this file.  The current version number is 1.10.6461.

 

If you don't have the Op Center, most likely you don't have the current version.

 

Mike

Share this post


Link to post
Share on other sites

@Scandinavian

Well.. If I load in the wrong plane .. then I have to restart and file everything again..

 

@Mike

I bought the box online from Aerosoft. I looks pretty new and it says also for FS:SE.

The current version 1.10.6461 (it says you're product is currently up to date as wel)

 

Thanks,

 

Collin Meerman

Share this post


Link to post
Share on other sites

 

 


Well.. If I load in the wrong plane .. then I have to restart and file everything again..

 

So be a little more careful when selecting the aircraft.

Share this post


Link to post
Share on other sites

Yes.. But I think this problem should be solved because it's not normal if FSX crashes everytime you end a flight. Isn't there any solution for this problem?

Share this post


Link to post
Share on other sites

Yes.. But I think this problem should be solved because it's not normal if FSX crashes everytime you end a flight. Isn't there any solution for this problem?

 

FSX wasn't designed to handle the complexity that we're putting into it with our aircraft. It's unfortunate, but it's a fact of life for the sim.

Share this post


Link to post
Share on other sites

Hello,

 

I understand this.. and I have to accept this.

 

But, this still doesn't fix the problem with the ''bad spawn''

When I get into the game the screens are all black (like cold and dark), none of the switches are working and the engines are running. When I have this I have to completely start FSX up again which takes some time. How could this be fixed?

 

Best regards,

 

Collin Meerman

Share this post


Link to post
Share on other sites

 

 


How could this be fixed?

 

This can only be caused by one of two things:

  1. You've disabled (or are using some sort of program that disables) FlexNet.; or
  2. Have the 737 as your default aircraft in your simulator, or are otherwise loading the aircraft multiple times

Share this post


Link to post
Share on other sites

1. I don't have anything called Flexnet on my computer

2. As said.. the default airplane is the red ultralight.

 

This problem is annoying me because I have to restart FSX over and over to get a good spawn!

 

Thanks,

 

Collin Meerman

Share this post


Link to post
Share on other sites

 

 


1. I don't have anything called Flexnet on my computer

 

Open the Start Menu and type "services.msc" (no quotes) and then hit enter.

 

Find FlexNet Licensing Service in the list. What is it set to?

Share this post


Link to post
Share on other sites

It has no status and it's says manual. I have to options to start it manual, automatically (with a delay) or to switch it off

Share this post


Link to post
Share on other sites

 

 


Collin Meerman
Set it up so that is done automatically. Try this - click on your user name in upper right corner, click on My Profile, click on Edit My Profile, click on Signature, in Edit Signature enter your first and last name, click save  and your name will be on all of your posts.
  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this