Sign in to follow this  
Gunbjo

Process monitor with no manual

Recommended Posts

Hi again,

One thing was solved but now I've got another problem that happened to me also in Win7. At the end of a pretty short flight from Malmoe, Sweden to Berlin the immagine freezes short before landing. I have tried it twice and it happen more or less at the same place. Readig what to do in your CTD guide" I downloaded "Process Monitor" and it seems to consist of 3 folders but when I try opening the manual I can see the headings but nothing happen when I'm clicking them. It seems as the manual is empty. If anyone has experience of it, please describe to me in steps what I've got to do  to get something to send to this site. The program records everything from the moment it's started so 1 minute recording gives a several pages long list of events.

 

Very grateful for any help

 

Gunbjo

 

System:  Intel® Core i5-4460 CPU@ 3.20GHz  3.20GHz,    Ram 8 GB,   HD 1TB,  Win10 home, 64bit

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I thought I'd try to return to default configuration and now I see I've got 2 dll-xml files  and 2 exe-xml files, the second of both the groups called "Before Add-on". Do I need both?? If yes, I shall put both in a temporary folder?? There are also Simconnect.xml and LWcfg.xml files. I don't touch them?? There are also several .cfg files. I only need to put scenery.cfg into a temp. folder??

 

Gunbjo

Share this post


Link to post
Share on other sites

The process monitor might help if you have a freeze or crash occurring at the same location like I had and as suggested in the guide.  I use it mostly to see what's loading at startup (to the setup screen) then what's loading after I click on okay to load the flight.  For instance, I have a flight from Chicago to Washington, DC.  Why do I need to have something loading and taking up resources in Texas or California or in Europe?

 

 

 


I downloaded "Process Monitor" and it seems to consist of 3 folders but when I try opening the manual

 

There is no "manual" but just a help file.  That's Procmon html.  Just double-click on it and you will see Process monitor.  Double-click on Process Monitor and it will expand to all the contents.  Just do not understand what you mean by "3 folders".  Maybe you mean the Tabs, Contents | Search | or Index.

 

 

I thought I'd try to return to default configuration and now I see I've got 2 dll-xml files  and 2 exe-xml files, the second of both the groups called "Before Add-on". Do I need both?? If yes, I shall put both in a temporary folder?? There are also Simconnect.xml and LWcfg.xml files. I don't touch them?? There are also several .cfg files. I only need to put scenery.cfg into a temp. folder??

 

Gunbjo

Whenever you install a new product that uses the dll.xml or exe.xml, it will create a backup file.  So those that have "before FSDT" or something like that is a backup.  A backup file will not load so no need to place in a temporary folder if you plan on seeing if the dll.xml is causing your crashes.  The same goes with the exe before FSDT backup.  No need to move that.  Same goes with the scenery.cfg.  You will see many copies of the scenery.cfg.  The only one that will ever load is the one with the .cfg extension.  Anything else will not load.

 

Hope this helps.

Share this post


Link to post
Share on other sites

I have got "Appcrashview too, which seems easier to use than "ProcessMonitor" so I'll attach 2 crashes hoping it can explain why the freezes happen. When trying to paste I get a small window asking me to use that with help of "CTRL/CMD+v". I've got no CMD key and CTRL+v doesen't work. When I tried WIN. EXPL .EDGE it says that the sicurity settings prevent me from pasting directly into this window. Can't understand why I, the user, shouldn't be allowed to paste some words into a text file. And I can't find which settings are causing this. Anyone out there knows how to change it??  I almost start to whish going back to winXP. Very few problems then compared to now. I have also tried Goggle Crome and get the same window but no explaination.

Share this post


Link to post
Share on other sites

 

 


When trying to paste I get a small window asking me to use that with help

 

You just copy the crash report and then come here, start a new post, right click and select Paste.  You might have User Access Controls.  In the AVSIM CTD Guide, page 24, there's an explanation of how to disable User Access Controls.

 

Best regards,

Share this post


Link to post
Share on other sites

Sorry, but this small window still appears . The setting of the browser prevent the editor to access the clipboard data directly, though the UAC is on the bottom.

If I understand you right I should make a new topic, but the same is happening  there too. I have tried both right-clicking and using the icons above but the same window appears every time. It is really frustrating.

Share this post


Link to post
Share on other sites

Yesterday afternoon I started going through the CTD-guide and looking for the simpliest solutions to begin with. I started win up-date and there was one new upp-date  but it didn't help. I can't still paste directly  into this space. But I continued trying different suggestions and among them i looked in "Compatibility" were it was the setting WIN Vista. I changed to WinXP  and had to check  the" Run as an administrator" too. I think eighter of them or both were the solution because then FSX run even a little better from the beginning to the end. I think setting the compat. must be a very important way to avoid problems and issues but I haven't seen this  anywhere earlier suggested as an important and easy way to avoid problems.  Shoulden't this be maybe the first step to take when you start with FSX?? When using Win XP many years ago I remember having to set compat. to an an earlier version to be able to play an old game and it worked just fine. Is this also possible in Win7?

 

Thanks a lot for all your help, Jim.

 

Gunbjo

Share this post


Link to post
Share on other sites

 

 


looked in "Compatibility" were it was the setting WIN Vista. I changed to WinXP

 

This you must not do under any circumstances.  Just make sure "Run as Administrator for ALL Users" is selected.  Do not check any of the other stuff above that or you will have further problems.

 

Best regards,

Share this post


Link to post
Share on other sites

Thanks for the warning. I looked again in the compability settings and the setting was restored to "Win vista". When looking at the FSX box I saw it is made for Win XP and Win Vista so it is difficult to understand that it would create problems if I changed to XP. Well ,then I guess the important thing was the setting

"Run as administrator". Anyhow, now FSX is running as smooth as before, even if there are some stutters( I think it is called) now and then but never mind. I like having a good view of the landscape.

 

Greetings

Gunbjo

Share this post


Link to post
Share on other sites

You have other addons that were not made for XP.  I have seen many crashes that were caused by telling Windows 7 to make the product you are using compatible to XP.  So, go ahead and use it.  If it works for you, great.  Just remember if you get a crash in the future that you cannot figure out, then remember this warning.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this