Sign in to follow this  
Cjr60611

VATSIM ATC Sound Options

Recommended Posts

I'm new to VATSIM ATC and have a headset.  Done a few flights and I like the experience.  However, I would like the headset to only play ATC sounds - NOT ambient plane sounds (i.e., engines, AC, cabin announcements, etc.) Essentially, when using the headset all sounds play through the headset and none through the speakers.

 

Is there a way in X-Plane 10.50/Windows 10 to have headset only hear ATC and cpu speakers play everything else?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm new to VATSIM ATC and have a headset.  Done a few flights and I like the experience.  However, I would like the headset to only play ATC sounds - NOT ambient plane sounds (i.e., engines, AC, cabin announcements, etc.) Essentially, when using the headset all sounds play through the headset and none through the speakers.

 

Is there a way in X-Plane 10.50/Windows 10 to have headset only hear ATC and cpu speakers play everything else?

Go into xsquawkbox settings (in game) and set the option to the headset you want. I'm not at my PC so I cannot give any more info atm. :D

Share this post


Link to post
Share on other sites

Go into xsquawkbox settings (in game) and set the option to the headset you want. I'm not at my PC so I cannot give any more info atm. :D

Yeah, I did that but Xsquawkbox only allows for level adjustments and com 1&2 outputs.  That seems to be working fine but I can still hear plane sounds in headset.  Want the plane sounds on speakers (if possible).

Share this post


Link to post
Share on other sites

Is your headset USB? If it is not then you will not be able to do this.

Yes, it's USB.

Share this post


Link to post
Share on other sites

Okay on your desktop, right click the sound icon in the taskbar. Select Playback Devices, make sure "Speakers" (Usually RealTek) is set as the "Default Device," if it is not make it the default. Then in XSquawkbox in your sound settings set your USB headset as both input and output device for audio. 

 

This last part, I am not familiar with X-Plane check the sound settings in that and make sure Speaker or Realtek is set there as well. After that you should be good to go.

Share this post


Link to post
Share on other sites

Okay on your desktop, right click the sound icon in the taskbar. Select Playback Devices, make sure "Speakers" (Usually RealTek) is set as the "Default Device," if it is not make it the default. Then in XSquawkbox in your sound settings set your USB headset as both input and output device for audio. 

 

This last part, I am not familiar with X-Plane check the sound settings in that and make sure Speaker or Realtek is set there as well. After that you should be good to go.

Ahhhh!  I think you have resolved my problem.  Did what you advised and I'm able to dispatch all other sounds to the default speakers.  I think I have to restart Xplane for change to take affect (I'm in the middle of a flight).  I will do so once on the ground and report back on what happens.  Thanks for your help!

Share this post


Link to post
Share on other sites

Okay on your desktop, right click the sound icon in the taskbar. Select Playback Devices, make sure "Speakers" (Usually RealTek) is set as the "Default Device," if it is not make it the default. Then in XSquawkbox in your sound settings set your USB headset as both input and output device for audio. 

 

This last part, I am not familiar with X-Plane check the sound settings in that and make sure Speaker or Realtek is set there as well. After that you should be good to go.

Worked like a charm!  Thanks again!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this