Sign in to follow this  
snapitbik

Please how to get resolved for this ISSUE My traffic 6.0a

Recommended Posts

hi , i follow the instruction guide provided on this forum after adding scenery from scenery library  the message appears scenery.cfg  file error   scenery remote directory is invalid  would you like to unload it ,   can i know how to overcome this issue,.  i added all line in simobject,cfg and in scenery.cfg manually but still same error appear  please can i know ho to get rid of this issue


 


 


Best Regards


Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Start Prepar3D.  Click world (Top Left)  Click Scenery Library  Make sure you have Not got 2 MyTraffic 6 Scenery folder's in there,  If you have got a Wrong MyTraffic folder and the box is "Ticked"  You will keep getting that message.  Identify the correct one and remove the wrong one.    

 

You should have only 1 Mytraffic folder in your Prepar3D Scenery Library 

 

The correct folder is The MyTraffic folder  

 

 

 

24760907562_6068794c9e_o.png

Share this post


Link to post

Dear Poppet, 

 

I did the same instruction but still same error occurs, 

 

 

Best Regards

Share this post


Link to post

 

I have precisely the same issue with MyTraffic in P3D v3 (followed Poppet's excellent guide for installation and triple checked settings, but the error pops up when starting the sim).  I have been searching the forums for a solution but no joy yet.

 

Snapitbik:  If you find a solution, PLEASE post it.  Many thanks.

 

 

Regards,

 

Jodeci

Share this post


Link to post

Hello

 

What Exactly does the Message say ?  Does it give an [Entry} Number as to what Area is Invalid ?

 

 

Go to ProgramData \ Lockheed Martin \ Prepar3D V3   Right Click on  scenery.cfg   Open with <  Notepad   Go though your Scenery.cfg and look for a Corrupt Entry (Missing a Path or wrong Path\Folder) 

 

Basically Prepar3D is looking for something that's not there,  Its calling on a Path= that's missing

 

Carefully remove Complete [Area] that is Invalid, Leaving the same amount of space between the [Area] over and below

 

After you do this, Start Prepar3D.  Click world (Top Left)  Click Scenery Library    Just Click Ok  By doing this It will Automatically Renumber your [Area.xxx] in your scenery.cfg correctly 

 

Here is an Example of an Invalid Entry 

[Area.xxx]
Title=MyTraffic
Local=C:\MyTraffic Professional\SCENERY
Active=TRUE
Required=FALSE

It should read something like this

 

A default Install of My Traffic 6 

 

 [Area.xxx]

Title=MyTraffic
Local=C:\MyTraffic Professional\MyTraffic
Layer=126
Active=TRUE
Required=FALSE
 
Its possible that the Message you are seeing is not a MyTraffic 6 Message,  Go though your Scenery.cfg and look for any "All" Invalid Entries 

Share this post


Link to post

The fastest way to fix this is..........


 


Rename your scenery.cfg and force Prepar3D to build a new one. 


 


Go here: ►Local Disk (C:) ►ProgramData ► Lockheed Martin ► Prepar3D v3  scenery.cfg


 


Right Click on scenery.cfg and Rename it to oldscenery.cfg  This will stay in ProgramData so you can Inspect it further


 


By doing this Prepar3D will build a new scenery.cfg.  Launch Prepar3D and confirm if the message returns or not ?


 


If all is good,  Close Prepar3D,  Do you have any Orbx products ? Open up your FTX Control Panel,  Wait 10 seconds,  This will Insert your Orbx Entries back into your scenery.cfg 


 


If you have any other Scenery Installed apart from Orbx,  You can Manually add it through the Prepar3D Scenery Library


 


==========


 


After this you can then add the MyTraffic Professional\MyTraffic to your Prepar3D Scenery Library 


Share this post


Link to post

Dear poppet, 

 

Thank you for your support, Well Scenery Remote invalid message is gone now, but problem is i still cant find any traffic though i add scenery and it went through well no error msg but still no AI planes i checked traffic bar all set to full still no AI traffic  any solution,

 

Best Regards

Share this post


Link to post

No problem 

 

Can you Copy and Paste the Contents of your simobjects.cfg in your next post 

 

Also,  Where did you Install MyTraffic 6 to,  The default path ?  Or somewhere else ? 

Share this post


Link to post

hi  poppet,.  here it goes 

 

[Entry.0]
PATH=C:\ProgramData\12bPilot\SODE\SimObjects
TITLE=SODE Common SimObjects
ACTIVE=true
REQUIRED=false
[Entry.1]
PATH=C:\Program Files (x86)\12bPilot\SODE\data\SimObjects
TITLE=SODE Main SimObjects
ACTIVE=true
REQUIRED=false
[Entry.2]
PATH=SimObjects\Airplanes
TITLE=Default Airplanes
ACTIVE=true
REQUIRED=true
[Entry.3]
PATH=SimObjects\Avatars
TITLE=Default Avatars
ACTIVE=true
REQUIRED=true
[Entry.4]
PATH=SimObjects\Rotorcraft
TITLE=Default Rotorcraft
ACTIVE=true
REQUIRED=true
[Entry.5]
PATH=SimObjects\GroundVehicles
TITLE=Default Ground Vehicles
ACTIVE=true
REQUIRED=true
[Entry.6]
PATH=SimObjects\Boats
TITLE=Default Boats
ACTIVE=true
REQUIRED=true
[Entry.7]
PATH=SimObjects\Animals
TITLE=Default Animals
ACTIVE=true
REQUIRED=true
[Entry.8]
PATH=SimObjects\Misc
TITLE=Default Misc
ACTIVE=true
REQUIRED=true
[Entry.9]
PATH=SimObjects\Submersible
TITLE=Default Submersible
ACTIVE=true
REQUIRED=true
[Entry.10]
PATH=SimObjects\Weapons
TITLE=Default Weapons
ACTIVE=true
REQUIRED=true
[Entry.11]
PATH=SimObjects\Countermeasures
TITLE=Default Countermeasures
ACTIVE=true
[Entry.10]
Title=MyTraffic
Path="C:\MyTraffic Professional\MyTraffic\Aircraft"
Required=False
Active=True
 
my traffic is installed on default C:\MyTraffic Professional\ directory

Share this post


Link to post

Ok,  The Numbering at the bottom is incorrect

 

Change  [Entry.10]   To  [Entry.12]   By doing this Prepar3D will now see (-) (-) this Entry 

 

You will know if its set up correctly if Prepar3D takes a lot longer to get to the splash screen 

Share this post


Link to post

Yesssss,,,,,, At last it works thank you so much poppet for kindly support,  and OP  JODECI  please follow what  Poppet instruct it works, 

 

Thank you so much 

Best Regards

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this