Sign in to follow this  
curt1

Buggy autopilot?

Recommended Posts

I'm a long-time flight simmer and I know how to use autopilot on generally every plane I choose.  However, with the DO228 and using the F1GTN, there are bizarre times where everything is set up properly (course, glide-slope indicator, alt hold, etc...), and the plane will not capture the glide slope.  The annunciator shows that approach mode and glide slope are active, but the gs indicator arrow just drops below the capture point and I then need to fly it in manually.  There are times though when it does work perfectly, and I can't begin to figure out why it works at times and not others.  Anyone else have similar experiences?  

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Many views and no replies, so I'll assume it's not a common occurrence with others.  I'll study the GTN config and see if something is off there.  

Share this post


Link to post
Share on other sites

Many views and no replies, so I'll assume it's not a common occurrence with others.  I'll study the GTN config and see if something is off there.

Hi Curt, not got the DO228 installed at the moment, however did the GTN750 swap from GPS to Vloc on approach, if not you need to to press the CDI button on the gtn, It should do it automatically, but you may need to change the settings.

As I said won't be able to do any testing at the moment until I re-install it, I up in the 441 at the minute.

 

bob

edit.. you need to have the ILS in before the FAF, if you do a procedure for your arrival airport the ILS is transferred into the GTN for you but you need to make it active before the final fix ( think its the FAF not the IAF)

 

b..

Share this post


Link to post
Share on other sites

Bob, thanks for your reply.  I forgot to mention my issue pertains to RNAV Approach procedures, not ILS.  I investigated my GTN config file where I spotted a setting that was irregular compared to my other aircraft.  That may be the problem and I'll know in a few flights.

Share this post


Link to post
Share on other sites

I never had 100% success (if any) with RNAV approaches in the Carenado/Alabeo airplanes. So I would be interested if you manage to find something.

 

bob

Share this post


Link to post
Share on other sites

I had selected the airplane turboprop option for the DO 228 which shows up as a "4" in the config file.  I changed that to a "1" and flew several RNAV approaches and all went well.  I don't really think that's the problem area though, as it's just a graphic image on the map page.  I also made sure the GTN config of the DO228 matched my A2A Cessna config files, as it always responds as expected.  In time I'll know if that little change really made a difference or not, but so far it's capturing the gs for RNAV approaches.  Very weird.

Share this post


Link to post
Share on other sites

curt1, on 18 Nov 2016 - 4:28 PM, said:

I had selected the airplane turboprop option for the DO 228 which shows up as a "4" in the config file. I changed that to a "1" and flew several RNAV approaches and all went well. I don't really think that's the problem area though, as it's just a graphic image on the map page. I also made sure the GTN config of the DO228 matched my A2A Cessna config files, as it always responds as expected. In time I'll know if that little change really made a difference or not, but so far it's capturing the gs for RNAV approaches. Very weird.

Hi Curt, reinstalled the DO228. set up a short flight CYQQ-CYBL rnav +v app. 300 (thro' resip )

approached at 2000' @ 110 knts. the Gtn750 indicated Term then changed to LPV.

Glide Slope indicator became active but airplane didn't descend.

 

Not to sure which config file settings you altered.

Altered the GTN750 main config file-Autopilot to nav 1 ( as it seems to set it up on Nav2)

 

bob

Share this post


Link to post
Share on other sites
Bob, many thanks for taking the time to reinstall and problem solve.  I've copied my GTN,cfg settings below (I only use one GTN, the other I blocked out in the panel.cfg).  This is working so far, but I'm not convinced it's a solution.  The only change I made was "Airplane = 4" to "Airplane = 1".  

[GTN750.1]
TAWS Voice=0
Airplane=1
Radios=0
Autopilot=1
Mouse=1
Link CRS=1
Auto CRS=1
Fuel=1
Sound=0
Invert Mouse Wheel=0
Active Mouse=1
CPU Core=0
Play Click=1
VC Brightness=6
Color Airplane=0

Share this post


Link to post
Share on other sites

The only change I made was "Airplane = 4" to "Airplane = 1".

My value in the config file was 0 so I altered it to "Airplane=1"

 

did a test flight from KCLM RNAV 26 gps LP + V, approached at 3700' (iaf) then down to 3000' at next wp. (ie swapped form TERM to LP+V)

glide slope became active set altidude for 500' before it the mark but it stayed at the same 3000' alt , no decent, the ALT button stays on for some reason.

 

bob

 

EDIT... managed to have success, clicking the APR button within two KN of the FAF did the trick.

Share this post


Link to post
Share on other sites

I set up numerous approach scenarious to try to get it to fail, but it captured the glide slope each and every time.  Whether it was a conflict in the config file or user error, or maybe both, it seems fixed from my end. If it crops up again I'll report my findings.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this