Sign in to follow this  

Problems connecting in multiplayer

Recommended Posts

Me and a friend have been trying to setup a multiplayer session with P3D v3, where I start up a host session and my friend tries to join via IP, but he keeps getting 'unable to connect' messages.


Following the manual, I setup a multiplayer session (tried shared cockpit with PMDG737, as well as normal with each our own aircraft). All setting are the same as mentioned in the manual. We both turned off our firewall, to make sure no errors there could be bothering us. I forwarded ports 6112-6122 on my router. My friend uses direct connect via my global IP address (not LAN).


I've been searching several forums, but I only see the same description of procedures as in the menual and this is not working.


Could someone tell me what could be preventing us from connecting? Maybe give some advise, or point me to a post, or article that can give me additional explination, or anything that might be able to help me setup a connection?

Share this post

Link to post
Help AVSIM continue to serve you!
Please donate today!

Hey Demious, sorry you're having such a hard time.  My buddy and I just went through this exact same scenario about a week ago.  Sounds like you've forwarded the correct ports, and have both turned off firewalls.  This is on the right track, although there were a few other things we had to do.


1.  Make sure when you setup the port-forwarding you used your system IP's address, not the global.  This can be done by going to the CMD screen and typing in "ipconfig"  It'll list out a bunch of addresses, ipv6, v4, MAC, etc. Make sure you use the IPv4 address for your port forwarding.


2.  We had to disable both firewalls, the one on our PC's and the one on the router (not sure if yours or your friends has that, but its worth a check)


3.  I (I was the host, he was connecting) had to disable the IPv6 portion of my network card.  This can be done by going to your network adapter properties, and disabling the IPv6 adapter.


Sounds like a lot I know, but, it is worth every bit of effort.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this