Sign in to follow this  
wrap23

Aircraft CFG file can't find repainted textures

Recommended Posts

Attempted repaint for Virtavia UH-16 to use in P3D/FSX. The config file ignores my new textures and loads the fallback textures in accordance with the texture.cfg file.

I used Virtavia's Paint Kit PSD files. I edited in PhotoShop 7. I've tried using NVIDIA's plugin as well as DTXBmp to convert to DDS format. The files appear to convert properly to DDS using both methods. The are all viewable as thumbnails in the texture folder.

I have checked and tripple checked my config edit and everything is sequenced properly and points to the proper texture folder. Both P3D and FSX see the new aircraft but when it loads it uses the fallback textures from the generic texture file.

Any help would be greatly appreciated

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thank you for responding jeansy, I really appreciate it. I discovered my problem after changing the mip mapping settings without success. It was simply my file naming technique! I named my texture files with the name of my new paint--"dancer_1_t.dds", etc. I finally realized that all the texture files for the other 15 variants were named "HU16_1_t.dds", etc. When I changed dancer to HU16 the textures worked fine. Can't believe it was that simple!

I wish I understood the mip mapping settings but hopefully that will come later.

 

Thanks again!

Share this post


Link to post
Share on other sites

 

 


I wish I understood the mip mapping settings

When you save a texture with mipmaps it will contain progressively smaller copies of the texture within the same file.

 

So a 1024x1024 texture with mips will also contain a 512x512 version, a 256x256 version, a 128x128 version, etc.

 

The version that the sim uses depends on a few things, mostly the distance from a surface of the model to the sim camera.

 

In fact you have to be surprisingly close to a surface to see the texture at it's full resolution.

 

If you position the sim camera on the wingtip of the default C172 in a way that you can look down the length of the wing you will see the full res on the near wingtip yet on the far wingtip you will be seeing one of the lower res mips.

 

How these different res images get blended is affected by your filtering setting in the sim.

 

The theory is that the sim can save resources by not needing to display the full res on an object that is far enough away from the camera as to only cover a small amount of pixels on your screen.

 

Unfortunately the sim is overaggressive in it's use of mips to the point of having user aircraft appear blurry due to the sim using lower res mips.

 

This can be mitigated a bit by zooming in real close then zooming back out. This is a short term fix that can be avoided by not saving your user aircraft textures with mipmaps. Most modern hardware see no to little performance improvement with the use of mips, at the cost of very visible quality degradation.

 

Save mips for AI aircraft and static scenery objects.

 

regards,

Joe

Share this post


Link to post
Share on other sites

 

Unfortunately the sim is overaggressive in it's use of mips to the point of having user aircraft appear blurry due to the sim using lower res mips.

 

This can be mitigated a bit by zooming in real close then zooming back out. This is a short term fix that can be avoided by not saving your user aircraft textures with mipmaps. Most modern hardware see no to little performance improvement with the use of mips, at the cost of very visible quality degradation.

 

Save mips for AI aircraft and static scenery objects.

 

regards,

Joe

 

You have to be careful with some programs as failing to save with mip maps results in the all black texture,, for a while dxtbmp suffered this problem and I dumped the program, in its current form today I dont know if it still persists  and there where a few others  programs that didnt like saving dds files without mips,

 

moving onto nvidia tools best thing ive ever done

Thank you for responding jeansy, I really appreciate it. I discovered my problem after changing the mip mapping settings without success. It was simply my file naming technique! I named my texture files with the name of my new paint--"dancer_1_t.dds", etc. I finally realized that all the texture files for the other 15 variants were named "HU16_1_t.dds", etc. When I changed dancer to HU16 the textures worked fine. Can't believe it was that simple!

I wish I understood the mip mapping settings but hopefully that will come later.

 

Thanks again!

 

Yeah that will do it

Share this post


Link to post
Share on other sites

Thank you for your responses gentlemen. Those explanations are very helpful and much appreciated. I'm getting back into simming after many years. I flew numerous planes in the military and ultimately want to repaint each of them to represent my squadrons.

 

Thanks again

Don

Share this post


Link to post
Share on other sites

 

 


failing to save with mip maps results in the all black texture,, for a while dxtbmp suffered this problem

That was fixed in 2008.

Share this post


Link to post
Share on other sites

That was fixed in 2008.

really? there you go, its been that long since I stopped using that program

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this