Silderoy

P3D v3.4 MSVCR120.dll CTD

Recommended Posts

Hello,

In the last couple of days I have experienced too many CTDs to count. and all for the same error. the "MSVCR120.dll".

I searched the web and every crash by this module seems to be related to the PMDG B777. and here is the interesting part: I don't have the B777 :blink2:

This crash happens every time I try to start a flight, doesn't matter the aircraft and airport. as soon as the loading reaches 100%. flight loads, 2 seconds, freeze, Fatal error. :help:

<EventData>
  <Data>FSX.exe</Data>

  <Data>3.4.18.19475</Data>
  <Data>560b4abe</Data>
  <Data>MSVCR120.dll</Data>
  <Data>12.0.21005.1</Data>
  <Data>524f7ce6</Data>
  <Data>c0000005</Data>

  <Data>000182a4</Data>
  <Data>2e08</Data>
  <Data>01d2750cfd404572</Data>
  <Data>C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\FSX.exe</Data>
  <Data>C:\WINDOWS\SYSTEM32\MSVCR120.dll</Data>
  <Data>00f1abf9-e101-11e6-a92c-d43d7e545f00</Data>
  <Data />
  <Data />

  </EventData>

please ignore the FSX.EXE thing, its a solution I have for using P3D with FSINN. it was working with this before.

 

I do not recall installing anything new when that started... updated P3D a few days ago...

System info:
 

------------------
System Information
------------------
Operating System: Windows 10 Pro 64-bit (10.0, Build 14393) (14393.rs1_release.161220-1747)
Language: Hebrew (Regional Setting: Hebrew)
System Manufacturer: MSI
System Model: MS-7808
BIOS: BIOS Date: 07/11/13 14:40:33 Ver: 04.06.05
Processor: Intel® Core i5-3470 CPU @ 3.20GHz (4 CPUs), ~3.2GHz
Memory: 8192MB RAM
Available OS Memory: 8126MB RAM
Page File: 5513MB used, 10805MB available

Card name: NVIDIA GeForce GTX 760

Display Memory: 4095 MB

Dedicated Memory: 2017 MB

Shared Memory: 2078 MB

Driver Version: 21.21.13.6909
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Not Available
Microsoft Graphics Hybrid: Not Supported

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Microsoft Visuals are used by developers to make sure their product is installed properly as they intended.  This is why the Microsoft Visual C++2013 program is throwing the MSVCR120.dll error.  Something is not installed properly.  You know, it could be permissions.  I have said a lot of times and in the AVSIM CTD Guide that you need to right click your P3D.exe application, select properties, and then click on the compatibility tab and make sure the program is running in Admin Mode for ALL users (not just you as there is a default user and a system user and they want access too!!).

 

Another possibility may be if you are using legacy software like FSInn within P3D and you do not have the proper simconnect installed for legacy software.  The program cannot communicate.

 

Another possibility is the use of that ugly Estonia tool used to install legacy software or software not made for P3D.  P3D works perfectly by itself.  Then people install add-ons made for P3D and many add-ons not made for P3D (legacy software).  They then blame LM and P3D. 

 

I do not know what program you installed that installed and uses Microsoft Visual 2013 but that's a clue as it threw one of its files as an error.

 

When you start up P3D and load a flight, as I have stated many times, every module in your dll.xml and exe.xml plus every .dll in your main P3D directory is loaded.  So, if you are having startup problems, that is the number one target.  One of those .dll's (modules) could be out-of-date or incompatible or missing.  As I state on page 10 of the AVSIM CTD Guide, you need to rename your dll.xml, restart P3D and it will rebuild the default dll.xml (remember, there are two dll.xml's in P3D, one in the P3D.cfg folder and one in the scenery.cfg folder). 

 

Less likely, but it could be a problem with your p3d.cfg.  I always recommend renaming the p3d.cfg because people tweak this or have high settings.  It is the number one fix for all crashes/freezes.

 

Check out the AVSIM CTD Guide (link in my signature) for other possible fixes.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Thanks for the reply.

For your advice:

1. P3D is running as admin for all users from the 1st moment I installed it.

2. I have a unique solution (that I posted here on the forums as far as I remember) to operate FSINN with P3D. its working that way for months now with no problem.

3. Never used the Migration tool.

 

I've been doing some troubleshooting and found the DLL.XML to be the cause. I'm now running a series of tests to check what item withing the file is the faulty. midway through, I found VistaMare and FSUIPC to cause the crash. will update when finished.

Share this post


Link to post
Share on other sites

Status: SOLVED!

 

I had to delete the FSUIPC files from the modules folder and it worked. no more MSVCR120.dll! Shame I cant have the program tho... :unsure:

VistaMare seems to be a different problem and after checking online just disabled it...

 

Well now thats here for future reference and maybe someone will figure out how to make it work with fsuipc.

 

Thanks Jim for trying to help! :im Not Worthy: 

Share this post


Link to post
Share on other sites

Glad you got it fixed.  The fsuipc module is loaded via the dll.xml and why I recommend in the CTD Guide to move or delete the dll.xml (in P3D there are two, one in the same location as the p3d.cfg and one in the same folder where scenery.cfg resides), restart P3D and the default dll.xml will load.  If there are no crashes, then it is one of the modules in the dll.xml causing the problem.

The fsuipc is updated frequently and when there is an update to P3D so make sure you have the latest version installed.  A few months ago, we had one incident where everyone went crazy trying to find a solution to the MSVCR120.dll CTD.  There were several pages of individuals looking for a fix and they were blaming P3D and posted the problem in their forums too.  I suspect the fsuipc was what caused their problem too.  So your solution may have helped hundreds of other members here.

Best regards,

Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now