Sign in to follow this  

Picking up my GTX geforce 1060 in a bit, upgrade from GTX 670

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

I bought the same card from Amazon a few months ago and am well pleased. No problems and good steady framerates in both P3D and FSX Steam.

Really glad that I did NOT spend all those extra dollars for the "faster"card

  • Upvote 1

Share this post

Link to post
Share on other sites

Woo Hoo!!


Let me tell you, at first I was disappointed, and that was in Aerofly FS 2 that was fluidity defined with a 670.


It was jerky, and for the first time it was tearing without it set on sync instead of 120 FPS.


I tried P3D and it was better than AF 2.


Then it dawned on me, I had installed the driver from the CD and it wiped out my settings.


I went ahead and upgraded to the latest driver, then I set the global settings, and in them I made two changes, I set vertical sync to on, and then the buffering to on, then I set DSR to 4X, my natice is 1920x1080.

I opened AF 2 and flew at 4K (not real 4K mind you, but upscaled by DSR) and NYC was awesome and at the high DSR setting there was hardly a single bit of aliasing, maybe way off out there.

And flying over the mountains in Switzerland I was blown away at how much more real the mountains looked.


And all settings to ultra, the FPS might have not been the best, but it was so smooth.


Happy with Aerofly FS 2 now I went to P3D, and it was amazing, at 4K with the DSR, at FSDream team KDFW, in the PMDG NGX 737, I was getting about 20-30 FPS, maybe 18 or so here or there, but it was buttery smooth.


It sounds weird, but it was smoother than before without a great increase in FR's.


Although with another plane at another airport I do expect higher FR's.


Happy with P3D, I ventured onward to X-Plane 11 and although my FPS/FR's were not dramatically increased it was just like the others, so smooth.


I can say that once I even out my NCP/NI/and in sim settings that it will get even better.


I have zero buyers remorse.


Best of all before I forget:


Now when I open NVIDIA GeForce Experience everything is lit up, "Ready" all down the line, and that includes "VR ready."

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this