Sign in to follow this  
Helix1250

Not sure if I have problems.

Recommended Posts

Hi everyone,

 

I wouder if I can ask for your assistance, I experienced a few system hangs with MCE 2.9.6.1, updating to 2.9.6.4 seems to have cured that.

 

But during a flight last night I whilst requesting flows etc the VAS remaining was as low as 600mb, I recall a while back seeing VAS remaining being in the 1.2-1.6 gb. Is anyone else seeing a high VAS usage or is it just me?

 

I'm thinking that this might be the cause of my pervious MCE hangs. Can other let me know what your seeing fir VAS please:)

 

Edit: I'm referring to VAS of MCE not FSX-SE

 

Cheers Rob

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Rob, at first I thought you were referring to P3dv3.4? I can write a small book on that VAS usage...

 

From what I know, MCE runs outside of any VAS (P3d or FSX), so it will not have any impact on VAS remaining.

 

VAS (<4Gb) on the 32 bit FSX (and P3d) platform, is consumed by scenery, weather rendition, Big Iron add ons and poorly made add ons with memory "bleeds". The latter can be scenery or aircraft.

 

But MCE won't use any VAS.

 

Hope that helps.

 

Regards

 

David

Share this post


Link to post
Share on other sites

Hi David,

 

Maybe I'm reading it wrong on my screen then, on my screen I have the red text show up. The last thing listed is a VAS usage I believe. Now when I saw it read 600mb last night I compared it with the VAS checker I use for FSX-SE. FSX-SE was running at 2.3gb of used VAS.

 

So I, maybe wrongly took the figure as VAS usage for MCE. But with Sim VAS at 2.3gb I would have expected the text listed at the end of the MCE text to have shown a figure around the 1.6gb. But I was seeing 800 and down to 600mb.

 

I'm confused which isn't hard :)

Share this post


Link to post
Share on other sites

Hi everyone,

 

I wouder if I can ask for your assistance, I experienced a few system hangs with MCE 2.9.6.1, updating to 2.9.6.4 seems to have cured that.

 

But during a flight last night I whilst requesting flows etc the VAS remaining was as low as 600mb, I recall a while back seeing VAS remaining being in the 1.2-1.6 gb. Is anyone else seeing a high VAS usage or is it just me?

 

I'm thinking that this might be the cause of my pervious MCE hangs. Can other let me know what your seeing fir VAS please:)

 

Edit: I'm referring to VAS of MCE not FSX-SE

 

Cheers Rob

 

You can trust the figure shown between parenthesis as the remaining FSX VAS.

 

It is computed when you speak a command.

 

This is the reason why we chose to run MCE and the speech engine inside "mce.exe" as an external process. They have a full 4 GB to play with.

 

And you can have fun with FO, speak thousands of commands if you wish and not cross your fingers worrying a single mishandled command could bring your simulator down.

 

Wonder why you get all those "don't do this before that", "don't say this before saying that", or speak this exact sentence here with other voice based add-ons  :smile:

 

Worst case scenario, MCE or speech engine start playing up (example, headset USB connection becoming unreliable) and eventually die or get intentionally killed. Your flight, the most important thing, stays put.

 

Not sure what tool you used to measure FSX VAS. There are different ways to compute the VAS.

Share this post


Link to post
Share on other sites

Thanks for the fast reply, I downloaded the Microsoft process monitor that I see recommended by someone.

 

Rob

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this