Jump to content

Sign in to follow this  
Paul Schmidt

Mouse Clicks and Buttons stop working after a while

Recommended Posts

I got a problem that plague many others as I see in the net. Is there an "official solution"?

After a while the mouse clicks, switches and rotary knobs stop working in the PMDG 737 800 virtual cockpit. Sometimes some clicks still work, but most don't. It happens a varying time from 1 to 10 minutes after the start of the simulation. It does not happen in every flight. I have no details yet on what causes the issue. The PDMG is the only plane with that problem.

I tried readjusting the seat to the front, going full screen and back, switching views, but nothing works. Reloading the PMDG does not help too. Restarting the FSX helps, but the problem may strike again.

The system is Windows 10 (but I had the same problem in Windows 8 before) and it is FSX Steam Edition. The PMDG is the most recent (the configurator says so). The livery is Air Berlin, but it happens in other liveries too. Addons are only sceneries and ASN. I am not running any view system when it happens.

Thanks for help,

Paul

 

Share this post


Link to post
Share on other sites

Okay, I have a possible solution. But I do not know if it stands the test of time.

I disabled FSLOptions, FSLEvents and FSLSounds in DLL.XML. And see, no more mouse problems! FSL A320X is a wonderful simulation. But is has its share of problems. I hope that is the solution. Fingers crossed.

Paul

Share this post


Link to post
Share on other sites

I and others have had this problem for a long time now.   I went through a fairly detailed trouble shooting exercise via a PMDG support ticket about 18 months ago, but sadly I could not accurately reproduce it everytime, and the guys at PMDG didn't even see the problem. 

The only way around it I have found is to make sure any control yokes/rudder pedals are unplugged from the USB port until after the aircraft has finished its 15 second initialisation when loaded.  Once this has finished plug in the control yoke etc and in my case no more problems.   

I can generally say that I will have the problem if I forget to unplug the controls and move any button or axis or viewpoint before the initialisation finishes.

This works for me I cannot say it will work for others however it would be interesting to see what others find...  It is only the PMDG 737NGX (all variants)  that this happens on.  The PMDG 777 is not affected.

 

Best Regards

Andy

 

 


Andy Mahaffey

lntel  i7 6700k Skylake​ (watercooled)

​8GB RAM

NVIDIA GTX 960 Graphics

​Win 10, FSX -SE (with CH Pedals and Saitek Proflight Yoke)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...