Norry

Linda is not logging FSX controls

Recommended Posts

Hi, I am running Linda 2.9.2 with the latest registered version of FSUIPC (4.963)

 With the console viewer on, Linda logging is fine. However when I attempt to select any box on the "FSUIPC logging"  I get the 2 lines shown below come up on the console, and no FSX controls appear when buttons, (known to use default FSX controls) are pressed.

### Blocked: attempt made to change LogOptions via 3400, data 0x0001
FSUIPC logging bit set: 10  ----------(this logging bit is either 2, 6, or 10) depending on which option is selected.)

Any ideas what could be the problem?

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You need to change the Log Options settings in FSUIPC4.INI for LINDA to be able to active the 3 extra logging options. I can't remember the precise name but it is listed in the FSUIPC4 documentation for offset 0x3400. 

Share this post


Link to post
Share on other sites

Have been getting the same eror message.

Never had to make changes to my FSUIPC.ini file to make linda work, but will have a look at that.

Share this post


Link to post
Share on other sites
2 hours ago, madfred said:

Have been getting the same eror message.

Never had to make changes to my FSUIPC.ini file to make linda work, but will have a look at that.

This was a latent (dormant) fault in FSUIPC4 that was revealed when 4.962 was released. This is why user were recommended to install FSUIPC4 4.962a with LINDA 2.9.2. FSUIPC4 4.963 has now been released. Normal users will not need to edit FSUIPC4.ini.

Share this post


Link to post
Share on other sites

 

1 hour ago, ScotFlieger said:

This was a latent (dormant) fault in FSUIPC4 that was revealed when 4.962 was released. This is why user were recommended to install FSUIPC4 4.962a with LINDA 2.9.2. FSUIPC4 4.963 has now been released. Normal users will not need to edit FSUIPC4.ini.

From what you say above, as I have FSUIPC4 ver 4.963 installed I should not need to edit the FSUIPC4.ini file, but unfortunately I still have this problem. I found the offset 3400 in the documentation and it does refer to logging bits 1 thru 12 but I am sorry I don't have a clue as to how I would use this information to add lines to the FSUIPC4.ini file.

Share this post


Link to post
Share on other sites
10 hours ago, Norry said:

From what you say above, as I have FSUIPC4 ver 4.963 installed I should not need to edit the FSUIPC4.ini file, but unfortunately I still have this problem. I found the offset 3400 in the documentation and it does refer to logging bits 1 thru 12 but I am sorry I don't have a clue as to how I would use this information to add lines to the FSUIPC4.ini file.

Unless you are using the Console to develop new aircraft modules you can completely ignore the error line:

### Blocked: attempt made to change LogOptions via 3400, data 0x0001

It has no impact on the operation of LINDA, FSUIPC4 or your flt sim.

As you are a new member, it would suggest that you are not into advanced programming. Should I be proved wrong and you have a need to use LINDA to switch on FSUIPC4 logging options for IPC writes, FSX controls and VRi events then this might help. At the bottom of the notes on offset 0x3400, it states that FUSIPC4.INI can be edited to change parameter LogOptionsProtect to YES in the [General[ section to allow external programs to change the logging flags.

Caution: FSUIPC4 logging options if selected can seriously slow the operation of your flt sim.

Share this post


Link to post
Share on other sites

You are correct in assuming that I am not into advanced programming, I have built a flight sim with 5 Bodnar cards using Linda and the work of others on various libraries, notably, but not exclusively, Mark at Almost Aviation. I just thought it was time that I tried my hand at using Linda and Lua to make my own library of bits and pieces that have not, as far as I can tell, been covered elsewhere. Unfortunately, the first time I tried to trace fsx controls, as shown in the Linda manual using  the Realair Turbine Duke Cowl Flaps as an example, no FSX controls showed up at all. I checked the logoptionsprotect= line in the .ini file and it was set to Yes. I am just thinking it must be something that I have done or left undone in the set up of either Linda or FSUIPC.  

Having been rather negative with this thread I have to say that I am very happy with Linda, and for normal everyday use it makes things so much easier and more convenient. So thanks for that.

Share this post


Link to post
Share on other sites

I have finally solved my little problem as out lined above. I have found that by running the console and tracer with a default aircraft, then clicking the default aircraft switches e.g battery s/w the Linda console shows the FSX control selected. I then switched to the Realair Turbine Duke (which is the aircraft I was having the problem with), ran the Tracer/Consol and the FSX controls showed up just fine. I this may help someone sometime.

Share this post


Link to post
Share on other sites

The latest release 2.9.3 corrects issues with the automatic creation of key files  and the remembering of the FSXSYNC state reported on this and other threads. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now