Sign in to follow this  
julietsierrappl

Problems connecting view presets with macros on Corsair Scimitar mouse

Recommended Posts

Hello! 

To begin with, ChasePlane is a great product. It's what I always wanted for FSX back in the day, now P3D, and I cant think of simming without it now. The fact it's still in alpha and can only get better/more stable with time is great. Good job, it can only get better :)

Of course this is still in alpha so it´s not unusual to find things that don´t work well, or don´t seem to work well anyway.

One problem I have right now and would like to point out. I just bought the Corsair Scimitar mouse especially to use with P3D in conjunction with ChasePlane to easily control and change views with all those sweet side buttons on the mouse. To make things work I assign key binding/key combo  (making 100% sure it does not conflict with another binding in P3D, as in the key or key combination is absolutely not in use) to a certain view and register it with the "Presets" in the ChasePlane software. Then I make sure it works on the keyboard itself. Then I record that key/key combination macro to one of the buttons on the Scimitar mouse. 

Problem is it takes repeatedly pushing on the buttons for the views to kick in, it hardly works. I have tried many key combinations and made absolutely 100% sure that there are no conflicts, as in previous assignments in P3D have been deleted. Also, when I use the keyboard itself the views work perfectly and smoothly  so the key assignment works but the executed macro on the mouse does not, or hardly. You can press the key maybe 3-10 times and then it kicks in.

I know you guys are in alpha but just wanted to add a little to the conversation here on the forums. Any suggestions on what I might be doing wrong or if it´s something else.

Kind regards

Jon Sigard

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have you tried binding the mouse to some keys used by P3D (brakes, lights, etc.), to see how it works in that situation?

Share this post


Link to post
Share on other sites

Good question!

Yes tried binding the macros to default P3D commands like g - gear, F1-F4 throttle settings, flaps  F5 - F8, all work withouth a hitch, problems only seem to surface when i try to macro a random assortment (desperately trying to find keys that work) of key/key combos for views through preset settings in the ChasePlane software.

JS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this