mihalich

Map Control Crashes

Recommended Posts

  Hi,

    I know this is probably out of your control, but this remains one of the most frustrating issues of the app (i'm on the latest 2.2.1.0).  The map control crashes a lot, and mostly when i'm like 5-10 minutes away from landing. So my entire flight gets screwed up in the last few minutes cuz something in the map crashes, and a big red X is all that remains in the map area of the screen.  If i continue, the ATC part of the app mostly seems to continue to function at least, so i can continue the flight.  Sometimes though it seems like the copilot stops responding to ATC when this happens.  Not always though.

Thanks,

Joe

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Joe,

I know the frustration.  I haven't been able to do anything to fix this.  Other than one reported incident where AI Traffic was off, all of these "Red X" crashes seem to happen when the AI Traffic viewing is turned on and there is a lot of traffic to be updated.  That might also explain why it happens near the destination airport.

Here are some things to try, not in any particular order:

1) Reduce the amount of AI Traffic generated by the SIM

3) Be sure only airborne (1st click of the Traffic display button) is enabled.  The Ground traffic is shown when below about 3000 ft.

2) Periodically turn the AI Traffic viewing off in P2A and then turn it back on.  I haven't tried this, but it might clear the map buffer and start over again.

3) Turn AI Traffic off except to check it in critical times.  You'll still get ATC alerts for the traffic. 

Let us know if any of the above cuts down on or eliminates the "Red X" issue.  It might lead me to a way to prevent it programmatically.

Thanks,

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now