funkyhut1

Autopilot Tripping

Recommended Posts

Take off normally, gear up and then after passing 1,500 ft engage autopilot. It engages. FD is replaced by CMD. The after 5 seconds a yellow caution comes on, EICAS shows message Auto pilot disconnected and then the red warning that the A/P has disconnected. Silence the siren by pressing A/P assigned button.

Happens when setting up from SHORT, LONG and Cold and Dark.

Any ideas please. It's very frustrating. The 777 on the same rig with the same button allocations works a dream.

Thank You

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

12 minutes ago, funkyhut1 said:

Happens when setting up from SHORT, LONG and Cold and Dark.

It's happening with all panel states because it's being caused by your hardware.

Either calibrate it properly, or go into PMDG SETUP > and enable the setting that allows the AP to ignore your hardware while it's on.

Share this post


Link to post
Share on other sites

Thank you for your quick reply Kyle.

I changed the A/P engage to not realistic and it is still happening. Incidentally I'm pretty much on the ball regarding trim and control input.

Not sure how to check the calibration for this particular situation. And it's NOT happening with the 777.

The EICAS warning is >Autopilot. It puts a yellow line through VNAV and LNAV on the PFD.

And it only started doing this today after working just fine. No hardware changes.

Very frustrating.

Thanks.

Share this post


Link to post
Share on other sites
23 minutes ago, funkyhut1 said:

I changed the A/P engage to not realistic and it is still happening. Incidentally I'm pretty much on the ball regarding trim and control input.

This isn't the one that I was referring to (though I'm less helpful because I don't have the plane available to me to give you the specific setting). The Intro Manual contains the language that you'd be looking for, honestly. It specifically calls out hardware issues.

Please give the Intro a read any time you find you're having troubles like this. A quick CTRL + F would have you sorted a lot faster than waiting around here for answers, unless it's particularly complex.

This is more of a calibration issue at its core.

25 minutes ago, funkyhut1 said:

Not sure how to check the calibration for this particular situation.

Open a calibration window (either via the sim, or the control panel - it'll route you to the same spot). Watch the crosshair icon (+) on the screen. It's likely going to be out of center, requiring calibration to recenter it; or it will likely be shaking, which is either bad buildup of static in the port (unplug/replug occasionally to clear), or bad potentiometers (old hardware / low quality hardware).

27 minutes ago, funkyhut1 said:

And it's NOT happening with the 777.

The 747 is not the 777.

Share this post


Link to post
Share on other sites

Thank you Kyle.

I'm not the sharpest knife in the drawer. I've read the manual(s) many times but there's a lot to take in.

I have not the slightest idea what a Ctrl+F is about unless you're referring to turning on and off the PIC side FD. I don't understand how that relates to my problem. I have a button assigned to that. I a previous post I was asking if there was a way to gang the FD switches so that if you turned off one the other went to off too.

Now I understand what you mean by calibrate the hardware. By looking at the STAT page I could see a problem. I've done as you suggested and that seems to have solved the problem. My joystick is Logitech and not so old.

I'm of course well aware that a 777 is not the same as a 747. I mentioned it because I figured if the former worked but the latter did not it might offer whoever offered me help, a line of thinking or elimination.

So problem solved (thank you) and the moral of the story is during pre flight, check the STAT page and do the control surface checks.

Share this post


Link to post
Share on other sites
3 minutes ago, funkyhut1 said:

I have not the slightest idea what a Ctrl+F is about unless you're referring to turning on and off the PIC side FD. I don't understand how that relates to my problem

The sentence immediately before the CTRL + F reference was referring to the manual, and not the sim. CTRL + F is the common "find" function in just about any program. This browser is an example. If you hit CTRL + F while using the browser you're reading this message with, you'll note that you can begin typing something, which the browser will then find. Similarly, the PDF reader you use to read the Intro Manual will also have this function.

Share this post


Link to post
Share on other sites

Thanks for that Kyle.

At age 34 I still had no personal computers at work. For my generation, learning this stuff has been generally self taught in order to survive. Now at 69, sometimes it's still a struggle. 

Thanks for this gem Sir; if you're open to it, you learn something new every day. 

Share this post


Link to post
Share on other sites
52 minutes ago, funkyhut1 said:

Now at 69, sometimes it's still a struggle. 

I can imagine. Good on you for keeping up.

52 minutes ago, funkyhut1 said:

Thanks for this gem Sir; if you're open to it, you learn something new every day. 

You're welcome. Absolutely.

Share this post


Link to post
Share on other sites

Hi,

I have the same issue.

The spot in the introduction manual where this is listed is on page 101 and the title is "CTL INPUT WITH AP ON". It says (I am copying) - "This option allows the sim to ignore any hardware connected to the simulator when the AP is on. This is particularly useful if your hardware is prone to send spikes that occasionally disconnect the AP."

I am going to try that...

 

Thanks

Benny

Share this post


Link to post
Share on other sites
13 hours ago, BK said:

Hi,

I have the same issue.

I am going to try that...

Thanks

Benny

Hi Benny.

Did that fix it for you? It did not for me. I'm still having to check the hardware with the STAT Page on the EICAS every time and if it's just a bit off, re calibrating before T/O. Bit of a pain but all I can do for now. That checking is with the captioned FMC selection ON or OFF.

What I don't understand is why I'm NOT having this issue with the 777 or 737. IMHO, whatever Kyle is saying here, there is something different going on between the models which perhaps there ought not to be.

My hardware is a Logitech Extreme 3D PRO which is not old and has been very carefully looked after. All it does is PMDG before the A/P is engaged and after it's disengaged on approach. So no hard jerking or misuse as in other adventure games. It's set up in FSX and not FSUIPC.

Thanks.

Share this post


Link to post
Share on other sites

CORRECTION!

By setting  "CTL INPUT WITH AP ON" to DISABLE, the problem seems to have gone away.

Fingers Crossed!

Share this post


Link to post
Share on other sites
5 hours ago, funkyhut1 said:

My hardware is a Logitech Extreme 3D PRO which is not old and has been very carefully looked after.

That's really strange since I'm not seeing any issues with mine, and I use the same flight controller.

Share this post


Link to post
Share on other sites

 

On 3/25/2017 at 6:50 AM, funkyhut1 said:

CORRECTION!

By setting  "CTL INPUT WITH AP ON" to DISABLE, the problem seems to have gone away.

Fingers Crossed!

I would think that you need this function to be "ENABLE"d rather then disabled. Indeed , it is not completely clear in the Introduction manual text.

When it is Enabled you get 5% of null zone for the controls input (two lines below the subject function in the FMC). If the function is disabled the null zone is disabled (grayed out).

 

Tx

Benny

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now