Malam

ChasePlane Zoom

Recommended Posts

Hello,

I'm running the last version of P3D V3.

I've been using ChasePlane for some month now and never had any issues... until today.

Since the v0.2.5.4 update, the zoom is not handled by Chaseplane anymore and zooming through ChasePlane has no effect on the simulator. The only way I can zoom in/out is by using the p3d default controls. The same happens for the saved cam position : the zoom stays the one set via the P3D default controls.

Please help me...

Thank you in advance,

Malo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I can also reproduce this using v0.2.54 under both P3D v3 and v4, ChasePlane can't control the zoom in the sim in this latest version.

Share this post


Link to post
Share on other sites

We are still hunting those bugs in the latest version. For now, you can disable Experimental Versions and go back to the stable channel.

Regards,
Keven

Share this post


Link to post
Share on other sites

Thanks Keven, but I'm happy to continue testing.    Just trying to nail how to reproduce this every time at the moment, I'll post back if I can work it out.

Share this post


Link to post
Share on other sites

Can someone help me?  I have a slightly different problem.  I chaseplane loads fine.   If I go to an outside view, then go back in, none of my key assignments work.  I have to restart Chaseplane to get them to work again.  If I hit the keys and in wont change any views.    If I load the expeirmental versions, when I go to an outside view and go back in, my keys cause incrimental movements but won't change any views.  MY ZOOM ON THE USER INTERFACE NO LONGER WORKS AT ALL!!!!!!   :o(

Share this post


Link to post
Share on other sites

It seems that hitting "Recheck Configuration Files" brings all the functionality back in v4 and I couldn't reproduce the stuck zoom any more.   

In v3 I could reproduce the stuck zoom by starting ChasePlane before the sim, verifying that it all works in the sim, hitting "Recheck Configuration Files", then closing ChasePlane and launching again (leaving the sim running), this set the zoom level to 1 and changing that or pulling the zoom slider in the camera tab will change the number but the zoom doesn't change in the sim.

However in v3, after 3 to 4 iterations of the above, I could no longer replicate in either sim.

v0.2.56 just came down and I was able to replicate again in v3 just the once (the launch that ran the update), but that Recheck Configuration Files sorted it after a restart of the sim.

Share this post


Link to post
Share on other sites

It's not about the configuration, it's about the Launch sequence. If you are able to reproduce it, I need to know what launch sequence causes the issue.

Regards,
Keven

Share this post


Link to post
Share on other sites

We found something in the sequence. Let me know if the latest build fixes the issue

Regards,
Keven

Share this post


Link to post
Share on other sites

So far so good Keven - I've not managed to break it yet.   I had a few ChasePlane lockups when starting it after the sim, using it OK, closing the sim and then starting the sim again with the same instance of ChasePlane still running, but that is not consistent either (and may have been related to the Xtreme Prototypes aircraft I was using, I'll keep trying to recreate it reliably).   Even going from p3d v3 to v4 and back while keeping ChasePlane open works and it copes really well - I love that the presets are also all valid under v4 for the same aircraft as well, nice! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now