JoeFackel

Empty CDU screen after resuming saved flight

Recommended Posts

Hi Mark,

i've the problem that more or less every time i want to resume an saved flight the CDU on my tablet has a blank screen. Buttons work but not the display, is there a special trick i have to follow?

BR
Joe

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Joe,

can you try running SimServer.exe after you load the resumed flight?

Does it work then?

Regards

Mark

Share this post


Link to post
Share on other sites

Tried but no luck. The buttons on the tablet are working but the display is still dark.

Share this post


Link to post
Share on other sites

Deleted as couple of restarts seems to have solved a similar issue. Will report back if reoccurs.

 

Cheers

Edited by paulhand
Issue resolved

Share this post


Link to post
Share on other sites

Joe,

I would venture a guess and say that this is a bug on PMDG's side. The SimServer doesn't 'know' about saved flights. Also, there is no requirement as to when it is started.

So if it doesn't work if it's started after resuming a flight, then it's not receiving data from PMDG.

Are you happy to raise a ticket on their side regarding this issue?

Regards

Mark

 

Share this post


Link to post
Share on other sites

Can do so, no problem.

Just FYI, had this problem already with the NGX on v3 and now with the 772 on v4.

Share this post


Link to post
Share on other sites

Hi Mark,

got their answer:

Quote

Unfortunately none of us here own that software so I would have no way of reproducing the error.  I would recommend you go back to Simserver and tell them to look into the matter further and let us know what they find and then we will be happy to look at it.  We don't make it a habit to troubleshoot other developers software.

Can i support you any files so you can take a deeper look?

There's also an other thing i didn't told you in the first: i mainly use saved flights to fly, when i shut down the plane properly and get it on in advance of the next leg the CDU does show the display.

So i guess it may have something to do with the panel state. What i will try next time is when the CDU stays blank i will activate the F/O CDU on my tablet to check if the problem is also there.

Share this post


Link to post
Share on other sites

Joe,

make sure the battery switch is on and the aircraft is fully powered.

Currently, there is another bug on PMDG's side where the CDU's power flag isn't set properly. This means, the CDU would still display data even though it is actually unpowered in the simulation.

As such, I had to add a workaround for this where I check if the battery switch is ON or OFF. Not fully realistic, but better than nothing.

Maybe that's the culprit?

Regards

Mark

Share this post


Link to post
Share on other sites

In the resumed flights the Jet was always in the air so Battery switch and power is there for sure :-)

Maybe the query for the battery switch position has troubles if it is already set to on?

 

Share this post


Link to post
Share on other sites

Hmm, no, I don't think that's it. At least, I haven't had any issues with the battery switch query.

Let me look into the 'flight resuming' issue - I'm fairly sure it's on PMDG's side, but let me do a few tests during the weekend and I'll get back to this thread.
If I confirm it's a PMDG issue, I'll raise a ticket with them myself. They have been very supportive and friendly thus far.

Regards

Mark

Share this post


Link to post
Share on other sites

Hi Joe,

after running some tests, here is the deal:

- if I resume a flight without previously selecting a PMDG aircraft, then the CDU works as expected. So, for example, from the initial load screen.

- If I however select the aircraft first and then load the flight, then the CDU doesn't work. It will still send the keystrokes to FSX but the screen won't refresh. It will display whatever was displayed before loading the flight.

It seems, in general, PMDG doesn't like if the same aicraft type is loaded again (they strongly advise against this in their documentation). In fact, with the 737, you will see a popup message if you do this (even when loading a flight after having selected the 737). The 747 however, doesn't show this warning.

As such, I'm fairly certain this is a bug on their side and I will raise a ticket accordingly. Now, if they choose to rectify this or not, I'm not sure, as they have considered this a non-normal procedure. Why they removed the warning message, is a different question.

The workaround still exists, where you load the previously saved flight without selecting the aircraft first.

Note - the issue here does not apply if you just load the aircraft state from the CDU directly. This will work as expected.

I hope this helps

Mark

Share this post


Link to post
Share on other sites

So, if i understand you correctly:

In the initial screen there must be shown an other plane than the one which is used in the saved flight, right?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now