Sign in to follow this  
VFRHawk

Stop P3D v3 launching VR Apps

Recommended Posts

Hey guys,

I know this can be done, I just can't find where I found how before!

I have P3D, FI and a Rift.  When I launch P3D, it launches Oculus Home, and if I kill the OH services, then it loads SteamVR!  I'm sure there was an ini file tweak that allowed me to turn off that behaviour.  Anyone know what it is?

Graham

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

This is what I use, and the commands are quite simple.

Copy this into a text file and save it as a .Bat Click it to run

@echo off
echo Preparing to disable Oculus Runtime Services
pause

net stop OVRService

echo Oculus Runtime Stopped, enjoy your non-VR experience
echo When you're ready to re-enable VR
pause

net start OVRService

echo Oculus Runtime Services have been re-enabled
echo Enjoy your Virtual Reality experiences and
pause

 

Share this post


Link to post

Recently I removed the VirtualReality.dll that is found in the main P3D folder and it works a charm. I'm using V4, and I learned this and it no longer fires up the rift. If I want to use vr I just insert the file back were it belongs. I imagine v3 is similar.

Share this post


Link to post

You're a god amongst men ShabbyLeo!  Knew someone would know how I did it..  :)

As a matter of interest HiFlyer, you can stop and start the services using Oculus Tray Tool which is a sticky in the Oculus general forum if you prefer that method - I find SteamVr still starts up every time if I just switch the OVR service off, but renaming the .dll fixes both..

Thanks both

Graham

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this