jason99vmi

SODE encoding error

Recommended Posts

Hey Oliver!  Great tool!

 

I get this encoding error caused by SODE.  Not sure how to get rid of it.  Any suggestions?

 

2n7mwq0.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Jason,

funny that this keeps coming back, looks like everyone who is running SODE has this?

The program that is required is called "Notepad++". https://notepad-plus-plus.org/

1. Make a backup copy of each file in the "incorrect encoding" message.
2. Open each file with Notepad++.
3. In the top menu bar there should be an entry “Encoding” - open that menu
3.a. For a "*.cfg" file select “UCS-2 Little Endian” (some versions call it "UCS-2 LE BOM")
3.b. For a "*.xml" file select "UTF-8" (some versions call it "UTF-8 BOM") = you need the UTF-8 version with BOM
3.c. Some versions of Notepad++ have "Encode" (top menu entries) and "Convert" (lower entries). Usually "Encode" is enough to change the encoding
4. Make sure that there aren’t any “funny characters” in the text of the file now
5. Save and close.

Best regards

 

  • Upvote 1

Share this post


Link to post
Share on other sites
30 minutes ago, Lorby_SI said:

Hi Jason,

funny that this keeps coming back, looks like everyone who is running SODE has this?

The program that is required is called "Notepad++". https://notepad-plus-plus.org/

1. Make a backup copy of each file in the "incorrect encoding" message.
2. Open each file with Notepad++.
3. In the top menu bar there should be an entry “Encoding” - open that menu
3.a. For a "*.cfg" file select “UCS-2 Little Endian” (some versions call it "UCS-2 LE BOM")
3.b. For a "*.xml" file select "UTF-8" (some versions call it "UTF-8 BOM") = you need the UTF-8 version with BOM
3.c. Some versions of Notepad++ have "Encode" (top menu entries) and "Convert" (lower entries). Usually "Encode" is enough to change the encoding
4. Make sure that there aren’t any “funny characters” in the text of the file now
5. Save and close.

Best regards

 

 

Worked for the most part but when i save now it says this

2e5jozk.jpg

Share this post


Link to post
Share on other sites

Hi Jason,

that is probably UAC at work. When the program is supposed to access files in system (reserved) locations, you will have to run it as Administrator and/or give it administrator rights through the settings.

Best regards

Share this post


Link to post
Share on other sites

I'm using SODE and addon organizer but haven't encountered that encoding error. I have UAC always on but after the v1.5.3 SODE update it is necessary to run addon organizer as administrator, which I don't mind. Cheers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now