Sign in to follow this  
R Smith

Can't install Steves DX10 Fix.

Recommended Posts

Hi guys, need help.

 

I'm trying to install Steves 10x fixer V3.2.3 for my FSX-SE, but when i run the setup.bat if finds my FSX folder just fine but then gives me a message saying "Sorry cannot locate shaders10 directory in C:/Users/Richard Smith/appdata/local/microsoft/FSX"  then gives another message telling me to delete the dir Manually.

 

I've searched for the Shaders10 dir and its located in c:/users/admin/appdata/local/microsoft/FSX instead.   I've tried manually deleting the shaders10 dir and running the setup again but its gives the same error.

 

What am I doing wrong?

 

Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I am looking at pages 27 and 28 of the DX10 Fixer Manual and if things go wrong, uninstall.  Open up the DX10 Fixer and click on Libraries and click on Uninstall.

The Shaders10 file will not be developed until you turn on DX10 Preview.  What is wrong (I think) is you are looking in the wrong users folder.  You are looking in the Admin's user account.  You want to look into YOUR user account.  So, look in C:\Users\ and look for your username.  You may have to do it for C:\Users\AllUsers and Default users.  Hopefully Steve will jump in and give you some assistance or your can go to his support forum hosted here at AVSIM and ask your question there.

Best regards,

Jim

Share this post


Link to post
Share on other sites

That's the problem, it's not in the folder with my name on, its only in the admin folder.

 

Share this post


Link to post
Share on other sites

You are actually referring to the unsupported freeware fixes from the avsim library  not the DX10 fixer which is an entirely separate product.  This has rather misled Jim. 

Since your compiled shaders are in the admin user directory then that means that you must always run fsx as administrator (or you run something else as administrator which launches fsx e.g REX perhaps.)   

You need either run the setup.bat as administrator or (easier) simply delete the shaders10 directory  under c:/users/admin/appdata/local/microsoft/FSX that you located.  When you run fsx it will rebuild it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this