guenseli

Please help with joysticks in USB Hub

Recommended Posts

Hello,

I have some problems with my devices connecting them to a USB hub.

 

What I have:

Warthog throttle and Joystick

Bodnar BU0836X (just for a switchpanel)

Bodnar Box Interface (just for a switchpanel)

CH Throttle Quadrant

Saitek Rudder Pedals

Saitek Switch Panel

 

System:

ASUS Z170-A Mobo, Win10 64bit, 750W PSU, 

Of everything the latest drivers

 

Problem:

When I connect my Warthog Throttle or Joy or the CH Throttle Quadrant, (even my normal mouse) directly into my PC, then everything runs fine when I start P3D.

But when I use a USB hub, what I really have to as the Z170 has so few USB plugs, my joysticks, throttles and the also my mouse are lagging heavily when P3D runs. The Warthog Throttles LEDs do also flicker.

 

I found out, that it depends on processor load, and P3D runs often at 100% CPU and then the lags come in. To simulate that behave I use Prime95 to get high processor load. have the exact behave then.

 

My question is, why isn't even the mouse able to be connected via an USB Hub without lagging then?

And of course I use powered USB hubs, I ordered just an industrial USB hub in hope to get this problem solved.

[edit] and I have disabled all Energy savings in energy options and device manager.

 

Any recommendations?

Many thanks

Günter

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Got an empty bay? 

I installed two of the front panel USB hubs that connect directly to the motherboard and are powered by a connection to the internal power supply.  Never had an issue with lagging.

 

Ernie

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for an answer,

 

yes, the connection directly to the mainboard with my front panel USB hub works indeed. It works now, that I arrange all my joysticks with axes to different direct connected hubs.

 

A friend has a relative similar PC with a lot of hoemcockpit stuff, but has no problems with USB hubs. (we indeed use the same hubs). And we do not figure out, why it is not working here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now