Sign in to follow this  
gamers22

FSX Freezes When Free Flight Is Selected

Recommended Posts

Hi all,

The past two days I've been dealing with an especially frustrating issue. Whenever my game loads, it has been loading in on the settings page in FSX. I go to select free flight and the Trike Ultralight does about half a turn and then suddenly my entire computer locks up. I can still click around and if I click the "esc" on FSX I can hear the click it is supposed to make. So it seems like its a video problem. I've deleted the logbook.bin, the fsx.cfg, updated the video driver and audio driver, and played around with my Nvidia Inspector settings (set them back to default). I've even somehow gotten FSX to start on the Free Flight page again like it is supposed but the exact same thing happens. Now, when I just have FSX and say, Spotify, opened, I can see the Ultralight rotating fine in the backround. The issue only happens when I select the simulator. I would do a repair but to be honest, I do not want to as my computer no longer has an optical drive so I would have to open up the case and wire an external optical drive in. This is completely frustrating and I am at a loss as to what to do. Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Could be your video card. How old is it? What are your system specifications and video resolution? Take a look here: 

 

Share this post


Link to post
Share on other sites
5 hours ago, vortex681 said:

Could be your video card. How old is it? What are your system specifications and video resolution? Take a look here: 

 

Resolution is 1920x1080

My specs are:

GTX 960

i5 6600K OC to 4.7 Ghz

8GB DDR4 RAM

MSI Z170A Gaming M3

 

I looked at the event viewer in windows and there aren't any errors in there. The only thing related to FSX is that it attempted to disable the Windows Task Manager. Not sure if that is normal or not.

Share this post


Link to post
Share on other sites

Did you try installing an older graphics driver as suggested in the linked thread ?

Share this post


Link to post
Share on other sites

When FSX starts up, it loads everything in the dll.xml.  Did you rename the dll.xml (if you have one as it is only installed with some payware items, including FSUIPC).  You should also try renaming the scenery.cfg and let it rebuild to the default.  If the freeze continues, you can bring the old scenery.cfg back as it is not the fault.  Same with the dll.xml. 

Share this post


Link to post
Share on other sites
1 hour ago, Jim Young said:

When FSX starts up, it loads everything in the dll.xml.  Did you rename the dll.xml (if you have one as it is only installed with some payware items, including FSUIPC).  You should also try renaming the scenery.cfg and let it rebuild to the default.  If the freeze continues, you can bring the old scenery.cfg back as it is not the fault.  Same with the dll.xml. 

I tried both of these with the same results. I'm not sure what is going on with the sim but it is quite frustrating

Share this post


Link to post
Share on other sites

I could try helping but your information isn't really sufficient enough as I'll have to look into it myself. We could use some sort of communication software such as discord or any of your choice if you'd like. Feel free to shoot me a message.

Share this post


Link to post
Share on other sites

I'm attempting to do a repair right now as I have run out of options. Will report back. Weird issue....

Share this post


Link to post
Share on other sites

Repair did not work. I'm in the middle of doing a clean uninstall/reinstall. Hopefully this fixes it. Thanks to all of you for your help

 

Share this post


Link to post
Share on other sites

Finally figured this issue out after purchasing P3D V4. The same issue was happening so I did a windows repair and it found a corrupt file. The repair fixed it and now both sims work. Now all I have to do is wait for all my add-ons to be compatible with P3D V4

Share this post


Link to post
Share on other sites
38 minutes ago, gamers22 said:

The same issue was happening so I did a windows repair and it found a corrupt file. The repair fixed it and now both sims work.

Unfortunately, you cannot do a Windows Repair so I suspect you did a check for corrupted Windows files by using the System File Checker as suggested on page 13 of the AVSIM CTD Guide. 

There is another way to do a Windows Repair without reinstalling Windows.  I use the Tweaking.com Windows Repair Program - http://www.tweaking.com/content/page/windows_repair_all_in_one.html.  This program is free (unless you want to do some other repairs which are not really needed).  I use it frequently.  It was developed by former and current Microsoft Windows techs and constantly updated.  A neat tool!

Best regards,

Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this