Zimmerbz

717 with Thrusmaster Warthog

Recommended Posts

Does anyone have any experience with setting up the Warthog correctly with the 717?  I have the registered version of FSUIPC 5 for v4 and I think I deactivated all of the P3D axis controls.  However, when I try to set it up in FSUIPC, when I get back to the sim, the throttle seems to activate revers thrust first and then when I advance the throttles more, throttle 1 and throttle 2 don't advance in synch even though they are linked on the throttle itself.  Can anyone point me in the right direction with some steps to fix this?  Thanks!1

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

to be more specific, if my throttle is all the way back in the idle position, and I advance the throttle to half way, that engages the reversers, when I push all the way forward, it decreases the reverse and adds full thrust.  I want reverse on the lever, but only if I pull up and backj

Share this post


Link to post

When you calibrate the throttle check the box for 'no reverse. Then assign the throttle detent as a button.

Share this post


Link to post

That didn't seem to work, unless I am doing it wrong.  Is there a proper sequence to calibrate?

Share this post


Link to post

First, you have to disable controllers in the sim. Next you set the axis assignment in fsuipc for what throttle you using; throttle 1, throttle 2. Complete the axis assignment and make it profile specific. Then go to joystick calibration in fsuipc and calibrate there. Select the calibration for separate throttles ( page 3 of 11). Then check the box 'no reverse zone'. You can check in the sim to make sure the throttle action is as desired. Then go to the 'buttons and switches' page in fsuipc. Again make it profile specific. Lift on the throttle handle and an assignment should load into the box.. Mine displayed 'joy 1, button 29'. Check the box 'select for FS control. On the right half of the page you see a drop down menu to make a selection. I use 'throttle 1 decrease'. Check the box below that ' control to repeat while held'. Next, below that another drop down box, select 'throttle cut'. You can check the operation in the sim for the desired result. I forgot, when you calibrate check the box 'send direct to fsuipc calibration'.

Edited by dheyer

Share this post


Link to post

when you have scanned the throttle choose the top option Calibrate......  then it will use the whole throttle 

Share this post


Link to post

now something even more weird is happening.  I deleted my .ini file to start from scratch and my throttles aren't recognized at all.  They show movement when I calibrate but the area in the sim where I set the null zones, etc is blank.  I tried the throttle in v3 and everything works perfectly.  That might be the problem.  How can I get that back?

Share this post


Link to post

Why did you delete the ini? I have the 717 in FSX and I now just installed into v4 with the 717 beta and set the throttles up as I suggested. Works fine. If you need to delete a set-up in fsuipc I just delete the section from the fsuipc config and go with it. In the sim I do not change any setting relating to control axis and I check the box 'disable controllers'. Once you disable the controllers you will not have any movement until you go through the calibration process in fsuipc.

Share this post


Link to post

If you are using the TARGET software from Thrustmaster I would suggest disabling it. The reason being I have read of people using it and having issues in flight sims. I don't use it and i don't have issues with my Thrustmaster.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now