rooitou

Not connecting to FSX

Recommended Posts

I've been using ChasePlane reasonably happily (bar the regular crashes) for a few weeks now and it's been functioning in FSX boxed, FSX Steam, P3D V3 and P3D V4.

However, today it just stopped working in FSX boxed, still works fine in the other three. It starts with FSX but then just shows a red box (with +TrackIR in it) at the top left and only Presets (with nothing in it) and Preferences available to click on. When I exit FSX, ChasePlane stays open wit the red box and doesn't auto-close. The "Start with FSX" option is enabled in preferences.

I know there must be an easy fix for this, but I don't even know where to start. The only thing I did since ChasePlane was working fine, was to install the Razbam Harrier GR.7-GR.9 aircraft, which loaded some control manager dll at FSX start-up. Not sure if this is even relevant?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Looked in VFX Central - Preferences and FSX is disabled (greyed out) in "Launch VFXCentral with" and I cannot change that

Registry Editor of VFX Central shows FSX unticked with path D:\FSX\Aircraft\Freeware\ Aeroprakt Foxbat\fsx.exe

That is the location of a freeware ultralight which I manually installed (copy & paste) from my HDD (on D: drive) to FSX Steam (on F: drive) a few days ago!? How on earth did VFX Central reroute my FSX path which is C:\FSX to that of a freeware aircraft add-on which was not even installed into FSX, but into FSX Steam on another drive altogether!?

I'm starting to really distrust ChasePlane! But more importantly, how do I get it back to C:/FSX because I cannot type anything into VFX Central? I checked in my computer registry with regedit.exe and the entry for FSX is correct as AppPath C:\FSX\

Share this post


Link to post
Share on other sites

VFXCentral uses the registry entries for FSX to know where it's located.
You might have changed something during your installation of that aircraft.
Simply click on the 3 dots in the Registry Editor and point it in the right directly.

Share this post


Link to post
Share on other sites

Hi Keven, the three dots were not visible at all as they were pushed off the screen to the right hand side by the long path description of the wrong FSX entry (I just shortened it in the post above, the real entry was D:\FSX\Aircraft\Freeware\Prop - Modern\Ultralight\Aeroprakt A-22 Foxbat Package\A22Foxbat-FSX\Aircraft\fsx.exe). Can I perhaps suggest that you re-position the three dots to the FRONT of the paths instead of the END, or make that window even wider? I had nothing to click on.

But i did find out in the meantime that FTX Central 3 (ORBX) also did not see my FSX installation, so I then realised that despite everything looking correct in the registry, that there must be some other registry "corruption" going on. I ran the FSX registry fix by Flight1 and both FTX Central and ChasePlane were fixed.

Share this post


Link to post
Share on other sites
1 hour ago, rooitou said:

Hi Keven, the three dots were not visible at all as they were pushed off the screen to the right hand side by the long path description of the wrong FSX entry (I just shortened it in the post above, the real entry was D:\FSX\Aircraft\Freeware\Prop - Modern\Ultralight\Aeroprakt A-22 Foxbat Package\A22Foxbat-FSX\Aircraft\fsx.exe). Can I perhaps suggest that you re-position the three dots to the FRONT of the paths instead of the END, or make that window even wider? I had nothing to click on.

Well, that's an unforeseen issue on our end. Thanks for pointing it out! The X on the left remains visible to remove the path and allow you to relocate it.

1 hour ago, rooitou said:

But i did find out in the meantime that FTX Central 3 (ORBX) also did not see my FSX installation, so I then realised that despite everything looking correct in the registry, that there must be some other registry "corruption" going on. I ran the FSX registry fix by Flight1 and both FTX Central and ChasePlane were fixed.

Great to read you had it fixed!

Share this post


Link to post
Share on other sites

I am having the same problem with Chaseplane not connecting to FSX:Deluxe.  Running the Flight1 registry fix did not help.

 

Does anyone have any ideas as to another way to fix this?  Thanks.

Share this post


Link to post
Share on other sites

@caleb1 go in VFXCentral > Preferences > Registry Editor and fix your simulator paths.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now