Sign in to follow this  
Flic1

P3D v4 stuck on intro screen

Recommended Posts

Well...I've been trying to diagnose BSOD problems for several weeks now (not P3D related) and I am now having a problem where P3D is stuck on the initial intro screen with a spinning circle:huh:  Sim has been fine otherwise.  I had flown Sunday and haven't touched anything since. I tried to open last night and had this issue (tried at least a dozen times to open).  Tried several computer restarts, deleted the main P3D .cfg so it could rebuild and also tried an uninstall/reinstall of client with no luck.  I have a feeling I'm looking at a full uninstall/reinstall situation but wanted to see if anyone had any other suggestions or advice before I pull the trigger on that. It's not anti-virus related as I check all of that and tried with it turned off as well. Thanks for any help!!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

See page 10, AVSIM CTD Guide (see link in my signature) regarding BSOD's.  The information you provided did not indicate a BugCheck Code or Description.

Best regards,

Jim

Share this post


Link to post
Share on other sites

So I had "solved" my original issue with P3Dv4 hanging at the intro splash screen by doing a full uninstall/reinstall of P3D shortly after my initial post back in August. Everything was running great again until yesterday when the same issue returned!!:ohmy:  No AV issues and nothing new had been installed since my last use over the past weekend.  I did try moving the dll.exe file out but the issue was still there.  Just for kicks, I went in to the 'Compatibility' setting (right clicked on P3D shortcut) and changed it to Windows 8 (I'm running Win 10) and magically it started!!  It will now only start in Windows 8 or Windows 7 compatibility mode:blink: If I uncheck that option it will hang at the intro screen and never load up. I'm confused by this and really do not know why this would be the case or if there are drawbacks to running in this compatibility mode.  I guess I will do a full uninstall/reinstall once 4.1 is released but I cannot grasp what could be causing this sporadic issue.

Share this post


Link to post
Share on other sites

Glad you got it figured out.  Most fixes to P3DV4 startups are done by the user investigating the problem.  The CTD Guide shows many reasons one should look at as they are solutions found by other members here at AVSIM and at other flight simulation websites on page 31.  I thought earlier the BSOD's were causing your issues but see now you had them several weeks before you posted here and you got the BSOD's fixed. 

Your solution is the first one I have ever heard of but, if it works, it works.  I have never heard of anyone changing this compatibility setting and I strongly do not recommend it for others.  I have a similar system as yours and I had startup problems a few weeks ago.  I was truly frustrated!  But I was getting a CTD before it crashed and the faulting module was always the fsui.dll.  I have two monitors and discovered I was in full screen during the last successful session I had with P3DV4 and shutdown P3D in full screen.  Not good!  So I went into the p3d.cfg and set the setting Maximized in the Main section to 2.  That brought the screen back to Windows.  Since you deleted the p3d.cfg and reinstalled the client, that problem should have been fixed for you as I believe the default is 1.

Hope you can now enjoy P3DV4 w/o further crashes or hangs.  Thanks for letting us know how you fixed your problem.  Could help others!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this