Nick M

RXP GNS 530W V2 integration with A2A KAP 140 autopilot

Recommended Posts

There was some discussion of this subject in Orlaam's topic on lateral tracking issues with the A2A S-TEC 30 autopilot, but as this is a separate issue I've started this thread to avoid confusion.

The problem I encountered was the A2A KAP 140 autopilot simulation failing to follow vertical guidance from the GNS 530 for approaches such as LPV and LNAV+V procedures. In response, Jean-Luc made the following comment here.

Quote

[...] Nevertheless, if they have implemented a custom A/P, which works based on normal simulator data (such as LOC/VOR radial signal, HSI needle deviation etc.., the reason it doesn't work in LPV might just be they have not accounted for any GPS LPV because the default GPS is not offering vertical capabilities.

However, if they only rely on 'radio-like' signals to feed their A/P code, then, it might be as simple to do vertical guidance as they do horizontal guidance when using our GNS V2, because we do override HSI, NAV and GPS sim variables (and module_var as well).

By the way, have you tried this A/P when you enable "Connect GPS to VOR indicator" in the settings panel?

This settings makes the GNS V2 override all 'NAV' related variables.

This works the same way "Connect GPS to HSI" makes the GNS V2 override all 'HSI' related variables.

NB: your GNS V2 must be the 'Master' otherwise it won't override the variables!

As suggested, I tried an approach with the "connect GPS to VOR indicator" option selected and the autopilot indeed intercepted the GPS glideslope. This would seem to be a good solution, except that it  renders the NAV2 radio inoperable!

I did note the guidance on page 114 of the GNS 530 Pilot's Guide: "Enabling Autopilot Outputs for the King KAP140/KFC225." At first, I though this may be relevant to trying to troubleshoot the issue in question. However, presumably this procedure of manually enabling autopilot outputs during each relevant approach isn't included in the trainer because it's autopilot specific?

Anyway, still hoping a workable solution can be found as I'll be using the GNS more-or-less exclusive in A2A products. :wink:

Thanks,

Nick

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This is a good wrap up and description! The real GNS output setting is for feeding real voltage to real wires!

In the virtual world, there is nothing more needed than sharing data the way we want.

Your test seems to concur what I've said: because the default GPS is not designed for vertical guidance, their A/P was not designed to follow the vertical needle when in GPS mode. However, when in VLOC mode, they do, and they probably do so based on the VLOC data (needles). 

To solve this problem: just have their A/P follow vertical guidance whenever there is a valid signal (not flagged). When doing so, regardless if the input is from a GPS (ours), or a VLOC radio, their A/P will track it!

Share this post


Link to post
Share on other sites
25 minutes ago, RXP said:

To solve this problem: just have their A/P follow vertical guidance whenever there is a valid signal (not flagged). When doing so, regardless if the input is from a GPS (ours), or a VLOC radio, their A/P will track it!

Thanks, though I'm not sure I follow this correctly. Do you mean there's something I can do in terms of how the GNS and/or autopilot is configured to solve this, or that it's something that requires attention at developer (i.e. coding) level?

Nick

Share this post


Link to post
Share on other sites
12 minutes ago, Nick M said:

that it's something that requires attention at developer (i.e. coding) level?

Most likely! But given they've implemented their own tracking code based only on signals like 'needle deviation' (per my understanding of your explanations), it sounds like they just have 'disabled' vertical tracking when in GPS mode.

Your tests with 'Connect GPS to VOR indicator' indicate their code is perfectly capable of tracking the 'needles' our GNS is overriding, so it would be as capable of tracking the 'needles' from the HSI, like from this set:

"HSI CDI NEEDLE,percent"   
"HSI GSI NEEDLE,percent"   
"HSI CDI NEEDLE VALID,bool"
"HSI GSI NEEDLE VALID,bool"
"HSI TF FLAGS,enum"        

As a matter of fact, they just have to enable their vertical tracking not just when it is in NAV mode, but also when in GPS mode. A simple change. In other words, enabled vertical guidance not based on GPS/NAV mode, but based on "HSI GSI NEEDLE VALID" only!

Share this post


Link to post
Share on other sites

Okay - thanks for the clarification Jean-Luc. Incidentally, are you in contact with the A2A guys regarding them officially supporting the new GNS units in their current and future fleet?

Nick

Share this post


Link to post
Share on other sites

No I'm not! However, if their A/P is coded in XML, it should be a simple fix! 

Share this post


Link to post
Share on other sites

Let's hope so! And hopefully you'll be able to work with A2A (as well as other developers) over the coming weeks and months to get the new GNS (and GTN when they're available) products supported as widely as possible.

Nick

Share this post


Link to post
Share on other sites
19 minutes ago, RXP said:

if their A/P is coded in XML, it should be a simple fix! 

I meant a user done fix, that is something you can do yourself. Is this A/P gauge coded in XML ? (i.e. the file extension is .cab)

Share this post


Link to post
Share on other sites

No - as far as I'm aware, all of A2A's avionics are encoded within DLLs.

Nick

Share this post


Link to post
Share on other sites

Hello Jean-Luc,

Just wondering if there's any likelihood of a solution for this issue? I figured the GNS V2 would work OK with the A2A add-ons as V1 is supported, but starting to think this may have been a mistake.

If it's any help, I've pasted an extract of the legacy RXPGNS.INI below which A2A provides with the installation, presumably to help compatibility between the V1 unit and their code. Just wondering if it gives any clues as to what settings in the V2 unit will work best, as they don't seem to be exactly the same as the options below. (I didn't own the V1 product, so can't comment on how well it worked in respect to this issue.)

AutoPilotMode=2
Radios=1
LinkCdiKey=On
AutoCdiMode=0
AutoApproach=Off
LinkVor=1
LcdStyle=Off
AutoWidth=500
AutoHeight=360
Trainer=
NoKeyClick=Off
DisableRxTx=Off
AutoPowerOn=Off
AutoRadiosOff=Off
GndSpdFromDeltaLatLon=Off
AutoCourse=Off
LinkObs=On
ShadinFuel=On
RadioSyncMode=Full
Brightness=-1.000000
CrossFill=Off
TCAD=Off
Taws=On
TawsVolume=60

In particular, it's "AutoPilotMode=2" which I'm curious about.

Thanks,

Nick

 

 

Share this post


Link to post
Share on other sites

Hi Nick, the legacy had 2 modes: NAV or HDG. The former is the normal mode like with the GNS V2, the latter is only when there is no possible way to control the NAV A/P. In this case, the gauge changes the HDB bug instead.

Also, can you please let me know the exact file version of your simulator .exe file?

Share this post


Link to post
Share on other sites

Thanks -  looking at those settings and the LinkVor=1 line, I'm wondering if the GNS V1 integration with the A2A KAP 140 suffered from the same limitation; or are there  V1 vs. V2 code differences which could account for this?

7 hours ago, RXP said:

Also, can you please let me know the exact file version of your simulator .exe file?

I presume you mean the fsx.exe (FSX-SE: 10.0.6.61625.0) and Prepar3D.exe (P3DV4: 4.0.28.21686) - I currently run both. Or did you mean rxpfsxml.exe? (V2.0.0.0 - I installed the recent update.)

Nick

Share this post


Link to post
Share on other sites

Thank you. Yes I was asking for these (not rxpfsxml.exe). Are you sure your FSX-SE is not 10.0.62615 instead?

Share this post


Link to post
Share on other sites

Sorry, yes, a mistype! :blush: FSX-SE is 10.0.62615.0 though I've mostly tested in P3D. In any case, both sim platforms and the A2A products in question are fully updated.

Nick

Share this post


Link to post
Share on other sites
On September 2, 2017 at 11:40 AM, Nick M said:

ested, I tried an approach with the "connect GPS to VOR indicator" option selected and the autopilot indeed intercepted the GPS glideslope. This would seem to be a good solution, except that it  renders the NAV2 radio inoperable!

I realize I might have skip this initially. Just to make sure, when enabling this setting, the A/P then works ok? What do you mean more precisely with "radio inoperable"?

Share this post


Link to post
Share on other sites

Yes, if "connect GPS to VOR indicator" is enabled, the autopilot will intercept and track the GPS glideslope as it should. However, when this option is ticked and the GNS CDI mode is set to GPS, the GNS controls both the VOR1 and VOR2 gauges. In other words, the NAV2 radio can't be used for navigation at all, unless the GNS is in VLOC mode.

Hope that makes sense? Compare image 1 and image 2 if it helps, where NAV2 is tuned to the HQM VOR  (there's no approach loaded in the GNS). Even if I'm following a GPS flight plan or approach, it's always good to be able to use NAV2 and the VOR2 gauge to track ground-based navaids.

Nick 

 

Share this post


Link to post
Share on other sites

Ok we are getting closer!

If you "Connect GPS to VOR indicator", it uses "AutoNavSource" to override VOR1 or VOR2.

AutoNavSource is either automatic (in this case it is the same as the GPS "RadiosPair" setting, otherwise, you can specifically set it to the NAV# you'd want.

Can you please cross check your GPS#1 is COM1/NAV1 and AutoNavSource is automatic? 

If not, can you enforce AutoNavSource to NAV1 and see if your VOR2 indicator gets correct readouts?

If not, can you please swap the aircraft 'VOR2' with a default FltSim VOR2 gauge and see if there is a bug in either their VOR2 gauge (wrongly displaying VOR1 data), or a bug in our gauge (wrongly overriding VOR2 when it should override VOR1).

Share this post


Link to post
Share on other sites

Okay, thanks for the added information Jean-Luc; I agree that we seem to be getting there!

In answer to your questions...

1 hour ago, RXP said:

Can you please cross check your GPS#1 is COM1/NAV1 and AutoNavSource is automatic? 

Yes, the radio setting has always been "COM1 / NAV1" and VLOC source "Automatic (NAV1)".

1 hour ago, RXP said:

If not, can you enforce AutoNavSource to NAV1 and see if your VOR2 indicator gets correct readouts?

I tried changing it to "NAV1" too (and indeed "NAV2"), with no change in behaviour.

1 hour ago, RXP said:

If not, can you please swap the aircraft 'VOR2' with a default FltSim VOR2 gauge and see if there is a bug in either their VOR2 gauge (wrongly displaying VOR1 data), or a bug in our gauge (wrongly overriding VOR2 when it should override VOR1).

I took a slightly different approach, and just tested in the default P3D Maule. The result: if "connect GPS to VOR indicator" is selected, setting the GNS CDI option to GPS overrides both the VOR1 and VOR2 gauges as shown here, irrespective of whether the VLOC source option in the *.ini is set to "automatic", "NAV1" or "NAV2". (In the example, both NAV radios are tuned to a valid frequency, but their respective VOR indicators are each showing nav flags because they're being overridden by the GNS which doesn't have any GPS guidance active.)

From what you've said above, does this seem to indicate a bug with the RXP gauge?

Nick

Share this post


Link to post
Share on other sites

This effectively resemble a GNS bug which overrides both instead of only one. We'll review this and keep you posted.

Thank you for the additional details Nick, and for your patience!

Share this post


Link to post
Share on other sites

Okay, thanks for the quick reply. I'll hand fly LPV approaches for now - I can always use the practice, especially in IMC!

Nick

Share this post


Link to post
Share on other sites

Hi Nick, a quick update to let you know there is a bug in GNS V2 which overrides both VOR when it shouldn't. We're fixing it and will issue an update.

Share this post


Link to post
Share on other sites

Thanks Jean-Luc. Look forward to the update!

Actually, I have another quick question about integrating the GNS V2 with third-party add-ons such as those by A2A.

With the GNS V1, the 3-D modelled rotary knobs were apparently animated in the virtual cockpit and responded to mouse control; however, with V2 this feature does not work. Because of the lack of knob animation and sound effects, the feel of interacting with a real unit is rather unconvincing.

Just wondered if it's possible to address this in future?

Thanks,
Nick

Share this post


Link to post
Share on other sites

Hi Nick,

You might want to activate the "Use Legacy 3rd Party Aircraft Panel (L:Vars)" option in the settings (it's added in the v2.3.1 update). When active, GNS V2 exports the set of variables 3rd party aircraft may have used to synchronize 3D knob rotation with 2D knob rotation.

Share this post


Link to post
Share on other sites

Aha! Thanks for the tip. Yes, this works successfully once the aircraft in question is reloaded. :smile: No animation for the inner knob push action, but I presume this was a limitation of the GNS V1 integration too. (i.e. there's no L:Var for this event.)

Cheers,
Nick

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Nick,

Good news: the bug is now found an corrected in our dev builds. It was a nasty little logic error hard to pin point, but so obvious once found.

We'll wrap a new build very soon with the fix.

Speaking of needles, we've also added a new set of options to 'scale' the HSI CDI/GSI needles independently (mind you, not the VOR, only the HSI). There seems to be a number of gauges that don't entirely adhere to the SDK documented scales, so this will permit calibrating the needles to the precise deviation.

Typically:

  1. boot the GTN to the Instrument Test page
  2. open the Settings Panel (SHIFT+RIGHT click top edge)
  3. change the scale
  4. repeat to 2) until both gauge needles show 50% deviation

That's it!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now