Alvega

Not detecting key presses

Recommended Posts

I updated P2A to 2.3.1.0 but now it doesn't detect my PTT or SayIT key presses (they are set in the config). If i press PTT with the mouse it works but not if i press Q on the keyboard, which is the key i set for PTT (same for the SayIt key). It worked ok before the update (I had version 2.2.2.1 before). Why is this?

Thanks.

Edit: Also updated X-Plane from 11.05 to 11.10B3 but i guess that has nothing to do with the problem.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 I just tried and was able to set Q as the PTT Hot Key on my system. 

It's possible you don't have the Enable PTT Joystick Button option checked.  That would cause the Hot Key to not work.

If that option is checked and it's not working, You might want to try clearing the Hot Key setting and then set it again. 

If neither of the above  work, please email (admin @ pilot2atc.com) a screenshot of your Config-Btns tab. 

Thanks,

Dave 

Share this post


Link to post
Share on other sites

Guess something changed from the last version then, because I didn't have the Enable PTT Joystick Button option checked before (because i thought that was just needed if I wanted it on the joystick) and it worked.

I now enabled it and it shows "Button Number 0" but the Q key on the keyboard is working. Hope that doesn't mess with my joystick buttons, lol.

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now