C130FE

Still Can't Get MCE to work (3)

Recommended Posts

Hey Gerald, I got the license key,  installed it, but when I go to open FSX:SE I get the message: Flight Simulator is attempting to start "MCE" Do you want to run the program?  I click yes.  Nothing happens.  So I start over and click "No", and attempt to start MCE manually.  At this point I get a message that says: "Could not retrieve FS data!  Try restarting FSX, then MCE.  If problem persists, check fsInsider.dll is missing, manually copy it from unzipped package.  Run application wizard.  Ensure flight simulator program is run as administrator if starting FSX using a utility like FPS Limiter.  Make sure the utility is set to start as administrator."  I checked and the fsInsider.dll is in FSX.  FSX is set to run as administrator.  The only thing that changed is Windows 10 Creator Update was installed last night.  What do I do now? 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

53 minutes ago, C130FE said:

Hey Gerald, I got the license key,  installed it, but when I go to open FSX:SE I get the message: Flight Simulator is attempting to start "MCE" Do you want to run the program?  I click yes.  Nothing happens.  So I start over and click "No", and attempt to start MCE manually.  At this point I get a message that says: "Could not retrieve FS data!  Try restarting FSX, then MCE.  If problem persists, check fsInsider.dll is missing, manually copy it from unzipped package.  Run application wizard.  Ensure flight simulator program is run as administrator if starting FSX using a utility like FPS Limiter.  Make sure the utility is set to start as administrator."  I checked and the fsInsider.dll is in FSX.  FSX is set to run as administrator.  The only thing that changed is Windows 10 Creator Update was installed last night.  What do I do now? 

Run the app wizard.

I assume you installed MCE to default C:\Program Files (x86)\Multi Crew Experience\ folder. If not, suggest you re-install to default path.

Click Windows 10 menu Start->All Apps->Multi Crew Experience->Run app wizard.

No need for speech training.

Are you getting the prompt to authorize fsInsider.dll to run when launching FSX?

Is Windows UAC enabled or disabled? (it is enabled if you don't know what this means). No need to disable UAC.

If still no-go...

Go to C:\Users\your_user_name\AppData\Roaming\Microsoft\ folder.

Do you have only <FSX> folder inside it or both <FSX> and <FSX-SE> folders?

 

 

Share this post


Link to post
Share on other sites

Finally got it up and running.  Sorry for the hassle, and thanks for your help.  Well, not so fast.  It worked once, now I'm back to the exact same routine all over again.

Edited by C130FE
MCE not working again

Share this post


Link to post
Share on other sites
9 hours ago, C130FE said:

Finally got it up and running.  Sorry for the hassle, and thanks for your help.  Well, not so fast.  It worked once, now I'm back to the exact same routine all over again.

 

I am suspecting you have the dll loading for the boxed edition and not STeam edition.

 

To find the folders, your system must be set to "show hidden files and folders".

Go to Windows Control Panel and oprn <Folder options>

Go to "View" tab and tick option "Show hidden files and folders".

After that go to C:\Users\your_user_name\AppData\Roaming\Microsoft\ folder

Do you have only <FSX> folder inside it or both <FSX> and <FSX-SE> folders?

Share this post


Link to post
Share on other sites

Gerald, Using the path that you told me to use I only have an <FSX> folder.  Just want to let you know all of my Steam folders are on my D:  Don't know if that makes any difference.  This is the path for FSX:SE.  D:\Program Files (x86)\Steam\steamapps\common\FSX.  Don't know if that matters or you care.  Just trying to give you as much information as I can to help solve this.  BTW FSX:SE is still asking if I want to open fsInsider.dll.  My windows UAC is enabled at the lowest setting before being disabled.  Thanks so much for your help and I apologize for being such a pain.

Share this post


Link to post
Share on other sites

 

Sorry can I chime in and ask if it’s FSX-SE giving a issue when starting, saying it’s a  issue with the fsinsider.dll?

if it is could it be the Windows registry issue in this thread? I had this .dll issue a few times and the below link sorted me out.

Rob

 

Share this post


Link to post
Share on other sites
39 minutes ago, Helix1250 said:

 

Sorry can I chime in and ask if it’s FSX-SE giving a issue when starting, saying it’s a  issue with the fsinsider.dll?

if it is could it be the Windows registry issue in this thread? I had this .dll issue a few times and the below link sorted me out.

Rob

 

Rob, I did as you suggested and the following file is not there.

3) delete the key "C:\\Games\\FSX\\fsx.exe"="$~ RUNASADMIN IgnoreFreeLibrary<FSUIPC4.dll>"........... or it might say FSINSIDER.dll

Rodger

Share this post


Link to post
Share on other sites
2 hours ago, C130FE said:

Gerald, Using the path that you told me to use I only have an <FSX> folder.  Just want to let you know all of my Steam folders are on my D:  Don't know if that makes any difference.  This is the path for FSX:SE.  D:\Program Files (x86)\Steam\steamapps\common\FSX.  Don't know if that matters or you care.  Just trying to give you as much information as I can to help solve this.  BTW FSX:SE is still asking if I want to open fsInsider.dll.  My windows UAC is enabled at the lowest setting before being disabled.  Thanks so much for your help and I apologize for being such a pain.

It doesn't matter where any supported simulator is installed to.

When FSX prompts you to authorize fsInsider.dll to load, you need to click "Run" and click "Yes" in the subsequent dialog box.. Otherwise MCE won't be able to connect and will complain about not being able to access data from the sim.

To prevent FSX constantly prompting to run the dll, go to ers\your_user_name\AppData\Roaming\Microsoft\FSX\ folder and open "dll.xml" using Notepad.

There should be a section for each loading dll.

If the section related to fsInsider.dll has <ManualLoad>True</ManualLoad>, change it to <ManualLoad>False</ManualLoad>.

Save the file and restart the sim, agree for fsInsider.dll" to load if prompted, wait until aircraft is ready to fly, start MCE and it should be able to connect.

Don't worry, what you'll take from this will be precious in troubleshooting failed FSX startups due to some misbehaving add-on dll.

Now you know where to look.

 

 

Share this post


Link to post
Share on other sites

Ok Gerald, I've flew several times and so far everything works well.  Looks like you have gotten me straightened out.  Hopefully your migranes will stop for now.  Sorry for all the hassle.  I have learned a lot from this experience.(as painful and frustrating as it was) But I guess that's how you learn.  Thanks again for all the help and your patience.  It is greatly appreciated.  And thanks for what your doing for us flight simmers.  Great work.

Rodger

Share this post


Link to post
Share on other sites
2 hours ago, C130FE said:

Ok Gerald, I've flew several times and so far everything works well.  Looks like you have gotten me straightened out.  Hopefully your migranes will stop for now.  Sorry for all the hassle.  I have learned a lot from this experience.(as painful and frustrating as it was) But I guess that's how you learn.  Thanks again for all the help and your patience.  It is greatly appreciated.  And thanks for what your doing for us flight simmers.  Great work.

Rodger

My pleasure.

Good to hear finally up and running.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now