tadino

Speech Recognition

Recommended Posts

Hello,

I'm not able to get P2A to recognize my voice input. I'm running P2A with administrative rights. Windows is recognizing my voice without any issues though, I can dictate a letter in Microsoft Word without any problems.

But when I hit Practice in the P2A Grammar Helper and then hold the PTT button the application is not recognizing the input and I get the Full Txt: in the Practice Speech field. I do get the Speech Recognition Information screen and everything is looking good (see attached sreenshot). Even the phrase "Say Altimiter" is not being caught.

I checked the Listen to this device box in the microphone settings and I was able to hear myself just fine, I'm controlling on VATSIM as well and never had issues with my microphone. I also unchecked the Exclusive Mode in the microphone settings. 

I've attached a picture of my settings and the end result. 

https://imgur.com/a/Z8LMA

I'm using Windows 10 and the speech language is set to English in the Speech Settings.

I hope someone has a hint or tip for me!

- Tom

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Tom,

Thanks for the detailed report and screenshots.

On the Grammar Help window, what do you hear when you press the Replay button (to the right of the Practice button)?

Thanks,

Dave

 

Share this post


Link to post
Share on other sites

When I had this issue, turning off Enhancements in the microphone settings (in Windows) did the trick for me.

Share this post


Link to post
Share on other sites

Also, I recall other users who were also VATSIM users saying they had to "turn off" VATSIM because it was interfering with P2A getting the sound from their microphone.

Anyone out there on VATSIM that has had a similar problem?  Please chime in here.

Thanks,

Dave

Share this post


Link to post
Share on other sites

In the Microphone Properties under the Enhancements tab I do the have the option selected to disable all sound effects. I'm not running any VATSIM applications while I run P2A. It just seems like that P2A does not have access to the microphone, like I said if I hit the Replay button in Grammar Helper, it's just dead. If there would be a static noise or something that would indicate that something is trying to get through.

I also disconnected the headset that I use, that has a microphone and used the microphone that's build into the laptop but unfortunately with the same results.

Share this post


Link to post
Share on other sites

Tom,

Do you have the Microphone level set to 100% in the Windows settings.

Also, check the Windows Volume Mixer setting to be sure it is turned up.  Right click the Speaker in the Task Bar and select Volume Mixer then look for the P2A logo. 

Dave

 

Share this post


Link to post
Share on other sites

Thank you for your continuous support Dave. I checked the Volume Mixer and there’s no P2A logo or application listed, now that’s interesting. P2A is up and running though, with administrative right. All I see is the volume slider for Speakers/Headphones and System Sounds.

Share this post


Link to post
Share on other sites

The volume slider controls the program output volume.  If you're not hearing ATIS for example, that would be something to check.  I'm surprised there's not a slider for P2A.  You might want to check the setting for Sound Output Device in config. 

Here are some Microphone things to check:

1) Recheck that the microphone is set as the Default recording device in Windows.  It was in the picture, so this is probably OK.

In the Microphones Properties:

1)Check the volume level of the Microphone

2) On the Advanced tab, be sure the Exclusive Mode option is unchecked

In the Sounds Communications tab, check that the "Do Nothing" option is checked

Here are some more Rare Fixes

A) There have been a few users with USB headsets that worked on USB 2 ports and not USB 3 ports, so if you have a USB headset, try changing ports.

B) Another user had a new usb headset. It plugged in and was recognized as a headset, but wouldn't work. He finally installed the gaming software/drivers that came with the headset, and all the problems were resolved.

C)One user had some sort of conflict between Windows native audio drivers and the Asus audio drivers that he had installed to control his second sound unit. He then removed the Asus drivers ( actually he went back to a previous restore point) and the problem disappeared. So he thought it was very likely that they are preventing Pilot2ATC from accessing the mike.

D) Another user fixed their mic issue by going to the Windows Speech Recognition Training and setting the Microphone settings instead of the Headset settings to get the volume right for speech recognition.

 

Share this post


Link to post
Share on other sites

The good news is that it's working now. I went through the steps provided by you Dave and checked the microphone settings again. Made sure that Enhancements and the Exclusive Mode were disabled. I skipped the USB Headset tips since my headset has the 3.5mm jack.

I went into the Device Manager and checked under Sound, video and game controllers and I noticed that I apparently have three separate drivers installed there.

  • Intel Display Audio
  • NVIDIA Virtual Audio Device
  • Realtek Audio

I deactivated the first two devices and left only Realtek Audio enabled, since the Speech Recognition Information screen was showing Microphone (Realtek Audio) as the Active Default Input Device. 

I restarted the computer, launched PTA and the Grammar Helper, opened the Volume Mixer and saw that Pilot2ATC 2016 v.2.3.1.2 MFD was active. I started Grammar Helper and the Volume Mixer switched to P2A Grammar Helper. I tried practicing but it would not work, I realized that the speakers were not working.

I went back into the Device Manager and enabled the Intel Display Audio and NVIDIA Virtual Audio Device. Restarted P2A and tried it again and suddenly it was working. I'm not using my headset though, I'm using the build-in microphone, which I don't mind, I'm just glad that it is working now. I practiced a few phrases and the Grammar Helper picked them all up and the Replay function is working as well. 

So what I pretty much did was disabling the additional sound drivers and leaving only Realtek enabled, restarting the computer, launching P2A and the Grammar Helper and then enabling the other two drivers again. I'm not entirely sure if this is a general remedy that can be used but it worked in my case.

Dave, I appreciate your help immensely.  Now I can use the software to the fullest extent. 

- Tom

Share this post


Link to post
Share on other sites

Tom.

Glad you got it working.  And thank you very much for the detailed write-up of how you got it working.  It should help others.

You might be able to get the sound to come through the headset by experimenting with the Speech Output Device setting in P2A Config Speech tab, but at least it's working.

Thanks,

Dave

Share this post


Link to post
Share on other sites

A method that worked very well for me:

  1. Open the Grammar Help.
  2. Press the Print All.
  3. Chose to print as PDF if you can or if you wish to have it on paper your printer (Note that it is a lot of pages.)
  4. Close Pilot2ATC.
  5. Open any text editor capable of handling Windows speech recognition. (Notepad works fine or Wordpad)
  6. Go to Control Panel\All Control Panel Items\Speech Recognition and  Advanced speech options and make sure your profile name is selected.
  7. Start Speech Recognition and use the Printout from P2A and train your profile.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now