snpower

Optimize FPS with Ryzen 1600X

Recommended Posts

I'm three weeks into Prepar3D v4.x and four weeks into using my new PC - first Windows machine in 14 years!

I have an MSI Gaming Pro Carbon MB, 16 gigs of G.Skill Flare 3200 memory, Samsung SSD and EVGA 1080FTW. I have the Acer Predator 27" IPS w/G-Sync. Wasn't sure if that would help with FlightSims but I intend to do some other gaming so that's the why behind that.

Initially (base install) I was hitting 70-90 FPS. I have added ORBX, AS/ASCA, Drzewiecki scenery for NY Aiports, Milviz F-4 and Beaver. I am extremely satisfied EXCEPT when I hit the metro airports such as KEWR, KJFK. At first I was down to FPS in the teen's. I tried numerous changes to the settings without any luck and then changed Affinity Mask to 4092 (there was no entry in the .cfg file).

I'm now hovering around 30 FPS in those areas. Just looking for any tips on further settings/optimization. Still very much learning my way around Windows/PC's here. Perhaps killing some background processes would help... I've posted screenshots of my current P3Dv4.x settings...

ei49xy.jpg

t98ub5.jpg

s2a9o6.jpg

s2ryg6.jpg

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

New York kills fps for pretty much everyone, you can either disable some of the other unwanted airports in the package, or drop your settings. I had to do both to get acceptable frame rates.

Share this post


Link to post

Your settings look quite reasonable, but here are a couple of suggestions:

- Kill all the "startup" background processes you can (if you ctrl+alt+del and check the startup tab)

- Drop texture down to 2048 (unless you are using 4096 textures); you can bump texture filtering up to 16X

- Drop shadow quality down to high or medium

- Disable vegetation shadow cast (but keep receive)

- Disable terrain shadow cast (this will revert to the alternate terrain shadow rendering which is a bit more fps friendly)

Also, what are your traffic settings? Are you running AI aircraft? FSUIPC?

 

  • Upvote 1

Share this post


Link to post

30 FPS is much better than great, why would you need more FPS?

Leave it be and enjoy 30 FPS.

Share this post


Link to post

So I turned on V-Sync and Triple Buffering, then set FPS to unlimited. Probably got me 7-9 FPS on average better. I have a G-Sync monitor, 2K... so not even sure how all the technology interacts.

I'm not a FPS chaser - it was getting a little stutter y and blurry on me.

I'll continue researching and try out the ideas mentioned above. As long as it is fairly smooth I don't care about the absolute number.

Share this post


Link to post

Also try with V-Sync / triple buffering off in P3D, and Fast vsync set in the Nvidia Control Panel.

Share this post


Link to post
On 12/5/2017 at 2:17 PM, DylanM said:

Your settings look quite reasonable, but here are a couple of suggestions:

- Kill all the "startup" background processes you can (if you ctrl+alt+del and check the startup tab)

- Drop texture down to 2048 (unless you are using 4096 textures); you can bump texture filtering up to 16X

- Drop shadow quality down to high or medium

- Disable vegetation shadow cast (but keep receive)

- Disable terrain shadow cast (this will revert to the alternate terrain shadow rendering which is a bit more fps friendly)

Also, what are your traffic settings? Are you running AI aircraft? FSUIPC?

 

I have all AI traffic off save for ground vehicles. I do not, as of yet, have FSUIPC.

Share this post


Link to post

Your settings are weird its eating fps without better visuals. Try the follow:

Display setting page:

AA : 4*SSA.  Filtering:16x.  Triple buffering: checked

World setting page:

Terrain: all sliders at the max , except for mesh resolution set at 10m

Scenery objects: complexity at max, draw distance at max

Reflections: Check user vehicles, terrain, buildings 

Lightning setting page:

turn off dynamic lights and dynamic reflections (fps killers)

Shadows: Set shadow quality and shadow distance at ultra

Cast : uncheck Vegetation, particles and terrain (fps killer) 

Receive: uncheck Vegetation

Final note try to set your monitor refresh rate at 30hz! Enable vsync . If u get some stutter u can add fiber frame to your config file try 0.01.  

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now