OldFlyboy

HELP Please: Serious Control Problem with P3D v4.2

Recommended Posts

My Logitech/Saitek Pro system with a second Quadrant has gone haywire in this sim. For example: The throttle works perfectly in the Carenado PC-12, Alabeo Waco.
It does not work at all in the A2A J3.
With Majestic q400 the left throttle has only three positions: full idle, mid range, and full power. Right throttle works perfectly.
Other problems include mixture, propeller thrust.

In P3d v3.2 (.3?,.4?) All functions work as they should in every plane.
I have not a clue about what to try next. So far FSUIPC, in sim calibration, reinstalling p3d v4 client, uninstalling/reinstalling all USB connections have not helped.

Can anyone help me with this?
Windows 7 Ultimate OS
New ProFlight system is three months old

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If I were you (and this is how i do it) i'd disable the controls in P3D and just use FSUIPC for controls.  Ive noticed if I dont do this sometimes the P3D controls will try to over ride the FSUIPC ones.  Also remember that you can then have separate control bindings for different planes. 

Share this post


Link to post
Share on other sites

Thanks Kenny

I have tried that once before (quite a while back) with little success. However, tomorrow I will try that first thing. Maybe this time my luck will hold.

Share this post


Link to post
Share on other sites

There is also a throttle axis calibration utility in the Majestic Q400 control panel. Have you tried that ?

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now