vp49p3

Buttkicker Sound Source Problem

Recommended Posts

Hi--I'm running 5.22.2 in P3dv4.1 and am having issues with the Buttkicker sound source.  I use three sound sources.  The main source is a generic USB card and voice is from the onboard Realtek card.  The OPUS Buttkicker is on the SoundBlaster card recommended in the OPUS instructions, in a USB 2.0 power strip.  I always set the SoundBlaster as the source in the OPUS Buttkicker control and make sure it's running correctly before I start P3d.  I then shut down OPUS, start P3d and then re-start OPUS.  Most times when I start up OPUS after P3D, the Buttkicker sound source somehow switches to "No  Sound Source Selected."  OPUS won't let me change to the correct source, and the Buttkicker control window is messed up, i.e. I can see the SoundBlaster as the source, but I can't select it.  I then shut down OPUS in mid-flight and restart, but the same thing happens.

Any suggestions for a fix would be appreciated.

Thanks, Jay.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Opus just goes by the DirectX device list which can become a bit muddled. So try using the Audio Test dialog in Opus BK control program and select different output devices until you get the audio coming out of the correct USB device and feel the response in the BK. Then stick with that selection. Also check your device selection inside the sim to make sure it isn't attempting to use the USB card.

Stephen

Share this post


Link to post
Share on other sites

Hi There

This simply does not work. I have tried it many times. I even bought on your advise an expensive Sound Blaster X-Fi ! Pro USB stick.Every time when OPus starts up with Prepar3d, it choose another sound divice. I have to disable them all to get OPUS BK working 

This sucks, from the beginning on it sometimes works 2 or 3 times ans than it randomly choose one of my other sound device. And it is not possible to choose the Sound Blaster. I can choose it in the BK control, but it keep on using the soundsystem with it has started up.

Please can you give a working tip?

 

Thanks and regards,
Ed

Share this post


Link to post
Share on other sites

Mine works just fine. Again this is NOT our support forum, you should email or use SimForums.

I plugged my Sound Blaster X-Fi ! Pro USB (not very expensive) in to my assigned USB port and restarted my Win10. Then after restart I set the Speaker (SB X-Fi Go ! Pro) volume in Win10 (via the taskbar) to 100%, I ran P3Dv4 and ensured the sims speaker sound was still ok, then run FSISERVER and enabled BK Control. I selected the 'Speaker (SB X-Fi Go ! Pro)' device and then the 'Test Audio' option (had to press the ON button on the BK Amp to get the green light and adjust its output volume). All works just fine.

OpusFSI saves your settings in a file so you will have to have set the sharing and permissions to allow file access. Also do the usual and shutdown any AV and Win Defender. But all is working just fine here. Of course if your device disappears due to the USB powering down, or you keep unplugging and plugging it in again, then Opus will not be able to select it or its device number will keep changing.

Make sure your Windows op sys is NOT powering down the USB port or hubs. You will have to check that via your Device Manager and tell your Windows not to turn off power to the hub. It may be doing this as part of your selected power management. Try disable powering down on all your USB hubs.

Stephen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now