RatCat

Speech recognition problem

Recommended Posts

Hello P2A Support,

after spending a lot of time i can't fix the problem of my speech recognition of P2A. My Windows 10 computer setup is ok and i can use the internal speech recognition of microsoft very well. I have checked out all troubleshooting hints in the documentation, but the speech recognition of P2A doesn't work.

I had tried differnt microphones. Logitech HD Webcam C615 (USB), Sennheiser PC-3 (3.5mm jack). My motherboard is a ASUS Z270F with a internal Realtek High Definition Audio system.

Any hints what i can check out?

Regards
Tom

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Here are the most common things to check when ATC is not recognizing your speech:

  1. SWITCH SETTINGS: Check to be sure the Power indicator in the bottom left of the main P2A screen is green. If not, then you need to turn on the battery switch and avionics switch in the aircraft, or if that doesn’t turn it green, check the 2 options "Ignore Battery Switch" and "Ignore Avionics Switch" in the Config P2A Setup panel.
  2. VALID CALL SIGN: Make sure you are using a valid call sign by changing it to the default Mfg: Beech; Tail Number: N431VB and pressing the Save Button. You can send me a screenshot of this page and I will let you know if there is a problem with the call sign.
  3. VALID FREQUENCY: Be sure you have a valid frequency showing in the Active frequency display. Open the Radio Panel and check that the frequency selected has a valid controller assigned. Try swapping the active and standby frequencies a couple of times.
  4. PTT BUTTON: Use the PTT button on the main screen to eliminate the possibility of it being the Joystick button setup as the issue
  5. VALID PHRASES: Make sure the phrase you are using is appropriate for the controller. "Say Altimeter" should work with all controllers, so use it.
  6. VOLUME SETTINGS: Check the Windows Volume Mixer and be sure Pilot2ATC volume is turned up. (RIght click on the speaker icon in the task bar and select Volume Mixer). Also check the volume of the voices in P2A Config. On the Communications tab of the Sound dialog, be sure "Do Nothing" is checked for when Windows detects Communications activity.
  7. GRAMMAR HELP SCREEN AND DIAGNOSTICS: Try using the Grammar Help screen.
    • Press the Grmr Help button to the right of the Flight Plan
    • Pess the Practice button
    • Take a screenshot of the resulting Message box with the connection information and email to me
    • Try saying "Say Altimeter" with no other words. It should be recognized. Let me know the result.

Dave

Share this post


Link to post
Share on other sites

Hi Dave,

thanks for your help. All my setup and configuration tests runs under the same condition:
- Start a windows mirco recording test and playback to ensure proper settings.
- Start X-Plane, running in background, C172 at gat, engine is running, radio and avionics on
- P2A is connected to X-Plane (green PWR lamp is ON)
- P2A SayIT funktion works well. My Callsign and 'ready to Copy' phrase can i hear loud and clear from my speakers (mixer settings ok)
- Testing with mouse, keyboard and joystick trigger the PTT funktion (Grmr Help shows only "Full Txt:" ... nothing more)
- Testing PPT phrase "say altimeter" or "<callsign> ready to copy" no luck...

I can handle a flight controlling P2A by keyboard and mouse. Voice feedbacks are ok but the main speech feature doesn't work.

Tom

Grmr help

 

 

Share this post


Link to post
Share on other sites

Tom,

This sounds like there is a problem with your audio input...possibly a driver issue or a settings issue.  The microphone must be set as the default Windows sound input device.

When you are in the Grammar Help screen and not being recognized, press the "Replay" button.  If you hear what you said, then Pilot2ATC is receiving your microphone, otherwise, if you're not hearing anything with the Replay, then Pilot2ATC is not hearing the input and that explains the speech recognition problem.  Recheck the following:

  • Be sure your microphone is not muted on the device itself
  • Recheck that the microphone is set as the Default recording device in Windows.
  • In the Microphones Properties:
    • Check the volume level of the Microphone
    • On the Advanced tab, be sure the Exclusive Mode option is unchecked
  • In the Sounds Communications tab, check that the "Do Nothing" option is checked
  • There have been a few users with USB headsets that worked on USB 2 ports and not USB 3 ports, so if you have a USB headset, try changing ports.
  • Another user had a new usb headset. It plugged in and was recognized as a headset, but wouldn't work. He finally installed the gaming software/drivers that came with the headset, and all the problems were resolved.

  • Another user fixed this problem by uninstalling a couple of bundled Asus sound effects programs and the program then started hearing speech but could not recognize it. He then ran through the speech recognition training and it then could recognise the commands properly. 

Dave

 

Share this post


Link to post
Share on other sites

Dave,

I have download the newest Logitech C615 Webcam driver and installed this one. I have checked all settings again. The micro isn't muted, and is set as "default recording device". The recording level is ok. The device don't work in exclusiv mode and in communication tab is the option "do nothing" checked.

Result... no success. If i use the "Replay" button, i don't hear my voice input. After that i open the microsoft Speech recognition. I could open a notepad with voice commands and dictate some sentences flawless. I have connected the Webcam into a other USB port (front slot) with the same result.

A friend will give me tomorrow another mircophone with a USB connector. More result details tomorrow.

Thanks a lot.
Tom

Share this post


Link to post
Share on other sites

Goods news, bad news ...

I got a Sennheiser PC7 USB microphone from a friend. After connection and installation, i launched a test run. The new mircophone was defined as a the default recording and playback device.

P2A recognized my speech input!!! So far so good.

But the sound playback of X-Plane was now on the single ear speaker of the PC7 headset. I changed the playback default device from PC7 to my Speakers. At this point, P2A doesn't recognized my speech any more.

Why has P2A a problem with a other playback device?

Tom

Share this post


Link to post
Share on other sites

Tom,

P2A does not care what the default output device is for purposes of recognizing speech.  But something might have been affected when you changed the default output device.

Check the setting for the Sound Output for P2A.  Try changing it to the headphone.

Also, recheck that the PC7 microphone is still the default sound Recording device.

Dave

Share this post


Link to post
Share on other sites

I have checked again all your hints, but the result is the same. This software won't run on my system as expected.

Thanks you very much for your help.

Share this post


Link to post
Share on other sites

I have the same issue, absolutely zero speech picked up by my microphone in P2A, but it works in every other application I have ever used, Your software is faulty.

Share this post


Link to post
Share on other sites

DrUzi,

The software is not faulty.  There are thousands of users of this software out there.  It is just a matter of getting the environment set up correctly.

One thing you may need to be sure of is that you don't have the "Listen" function of the Microphone set to On.  That will cause feedback and prevent any speech recognition.

Also check the other settings as outlined above or in the separate post you made on this same topic.

To confirm that the Microphone is working, do the following:

  • Open the Grmr Help screen
  • Press the Practice Button and take a screenshot of the Dialog box that pops up. Send that back to me (admin@pilot2atc.com) to see your language/grammar settings.
  • Using the large PTT button on the screen, try saying just "Say Altimeter"
  • If the phrase shows up in green on the screen, your microphone is working. If not, press the Replay button and see if you can hear your voice saying the phrase

Dave

Edited by Dave-Pilot2ATC

Share this post


Link to post
Share on other sites

Hello Dave

I have a problem on my PC with select output devices.

I have 3 playback devices:

-  one USB headset,

-  one stereo speakers set (realtec Hight Definition audio)

-  one o.display screen with integreted speakers (Nvidia Hight definition audio).

I would like to use my headset for eared both xplane 11 sound and P2A ATC voices but when I select USB headset in windows and P2A, there is no ATC voices.

The ATC voices works only in speakers or screen when they are selected in P2A....

I have no problem on speech recognition with my headset.

Thanks for your help

Pascal

Share this post


Link to post
Share on other sites
8 hours ago, F_PASC said:

Hello Dave

I have a problem on my PC with select output devices.

I have 3 playback devices:

-  one USB headset,

-  one stereo speakers set (realtec Hight Definition audio)

-  one o.display screen with integreted speakers (Nvidia Hight definition audio).

I would like to use my headset for eared both xplane 11 sound and P2A ATC voices but when I select USB headset in windows and P2A, there is no ATC voices.

The ATC voices works only in speakers or screen when they are selected in P2A....

I have no problem on speech recognition with my headset.

Thanks for your help

Pascal

Thanks to cancel this post, I creat a new topics for this in reporting bug forum.

Share this post


Link to post
Share on other sites

I am having the same problem, except mine is hit or miss. Mostly miss (95% of the time speech doesn't work). Same as others, speech recognition works with Cortana and other applications.

Did all of the above, and from other similar threads with this issue and nothing seems to work. Thinking maybe there's a conflict with another plug-in, so I'm going to unload all non-critical plugins and see what happens. If something good happens I'll post back here.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now