jfwharton

V2.5.0.3 loosing connection to FSX SE

Recommended Posts

Lately when flying I get all the way to destination and while being vectored to approach or starting an approach Pilot2ATC looses it's connection.  Is there anything I can check that might be causing this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

What happens that makes you think it's losing its connection?

If running on the same machine as FSX, it's unlikely that there's anything that would cause a loss of connection.  FSUIPC is usually rock solid.

Dave

Share this post


Link to post
Share on other sites
Posted (edited)

While flying receiving vectors from Pilot2ATC my simulator paused for a while (not sure why, perhaps loading scenery as I use ORBX) and displayed not responding in the top border of the windows for FSX SE.  Then the connect button in Pilot2ATC went from green to not green and I hear a tone from my computer.  In the mean time I have renamed my fsx.cfg file and have started FSX SE to let it create a new one.  Also I use Active Sky Next, which has also been disconnecting at the same time as Pilot2atc.  So I'm doing some testing using FSX SE with Active Sky Next only and not using Pilot2ATC to see if I have an issue with Active Sky Next disconnecting.  From there I will add Pilot2ATC to the mix to see what happens.

Edited by jfwharton

Share this post


Link to post
Share on other sites

When FSX SE stops responding, that causes Pilot2ATC to not get a response from it,sensing it has been shut down,  and so it disconnects.

This is the correct behavior.  After you get FSX back up and stable, try connecting again.

Dave

Share this post


Link to post
Share on other sites

Is there any timeout setting that could be adjusted to help with this issue?  I seem to have the issue with the 737-200 aircraft I have, still testing to see where this happens.

Share this post


Link to post
Share on other sites

No, there's not a timeout setting. 

I will see about adding a "Disable Auto Disconnect" option in a coming update.  This might cause unintended issues, but at least it will be settable.

Dave

Share this post


Link to post
Share on other sites

No, there's not a timeout setting. 

I will see about adding a "Disable Auto Disconnect" option in a coming update.  This might cause unintended issues, but at least it will be settable.

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now