mihalich

Bugs working with taxiway points in Maint window

Recommended Posts

 

 

 

 

Hi Dave,

   I don't know what's going on with the gate and taxiway maintenance window, but i'm having problems working with the taxi points in the editor.  The same thing happens to me on any airport i try to modify.  I've created 2 videos that show the issues, links are below.

   The problem happens when i'm selecting points to modify the taxi point type, or delete it.  I will select a point, right click and delete it.  Then i go select another point, and when i select it, the previous point displays again on the screen, and when i right click on the new point i selected, the delete taxiway point option is grayed out.  I have to click off the point, (at which point the old point disappears again), and then select the point again for the delete taxi point option to enable.

  Similarly, occasionally I'll select a point, and set the taxi point type, then select a new point, and delete it, but the first point i selected and modified the type on, actually gets deleted, not the one i selected.

  Btw, not sure if it's related to this or not, but i imported the taxiways from x-plane 11 in the cases where this happens.  Haven't tried with the built in taxiways to see if it happens with those too.

  Not sure when this started...i'm on the latest version.

Joe

  Selection, modify, select new point, delete's old point: 

  Selection/delete grayed out issue: 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

If i had to wager a guess as to what's going on i would think it has something to do with multiple taxiway points having the same name (or id), and the code is getting confused by that.

I've noticed when i import taxiways from xplane a lot of taxi points show up with the same name in p2atc.

Joe

Edited by mihalich

Share this post


Link to post
Share on other sites

Actually it's not the point id or name directly.  The same thing happens to me when i load in KORD (unmodified from p2atc stock install), and try to do the same things.

Joe

 

Share this post


Link to post
Share on other sites

Joe,

The names can be the same.  Taxi Path names are important, taxi point names can be left blank.

If you're adding points or paths, then the ID is 0 until after you Save and that can cause problems.  So it's best to Save after adding any points or paths before doing any modifications.  Frequent Saves will reduce, but not eliminate the confusion.

The selection is relying on mouse click position and does sometimes get confused, or might select both a Path and a Point with a single click.  Or it might not sense that you have clicked on a new point and will display the old one.  It looked in the second video like you have the proper remedy which is to click on an empty area of the map then re-click the point or path you want. 

Hope this helps.

Share this post


Link to post
Share on other sites

  Is there any chance of getting this fixed in any way?  It's quite a pain in the neck to make the small changes i'm trying to make just to set up the hold short points after import.

  Joe

 

Share this post


Link to post
Share on other sites

Joe,

If you could email the saved taxiway file and Airport ID for the airport where you were deleting points and they reappeared, I'll load it and see if I can replicate the problem and try and fix.  I played around with a couple of random airports and didn't have the consistent problem you had in the second video.

Thanks,

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now