Sign in to follow this  
FalconAF

Remove AI Sleepers 1.00 b06 and Little Nav Map Problem

Recommended Posts

Sim:  P3Dv4.3

When I run Remove Ai Sleepers 1.00 b06 with the current Little Nav Map version, the AI aircraft on the Little Nav Map map display will not automatically update their positions anymore.  If I left click anywhere on the map display, all the AI aircraft will "jump" once to a new updated position, but then stay there.  I can repeat that with each subsequent mouse click on the map.  Interestingly, my own airplane will continue to update it's position automatically regardless of whether Remove AI Sleepers is running or not.  If I close Remove AI Sleepers, all AI aircraft will begin updating their positions in Little Nav Map automatically.

Don't know what is happening, but something isn't "playing nice" anymore between Remove AI Sleepers and Little Nav Map since I updated P3D from v4.2 to v4.3.  Don't know if it's a Remove AI Sleepers or Little Nav Map problem. 

Any ideas?

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

sorry, but I have never seen something like this before. Has LittleNavMap been updated recently? 

The RemoveAiSleepers is a very simple program, just watching the AI like a dozen other apps do too - and then removing some. It hasn't been changed since I released it. Maybe LittleNavMap doesn't like it any more that some AI aircraft are removed just like that, or it doesn't like the way how it is done. But then it should be in trouble with other AI limiters out there too.

I'm not using the LittleNavMap, but even if I did, I wouldn't even know where to start looking. Maybe the LNM developer has an idea?

Best regards

Share this post


Link to post
Share on other sites

I checked and I have the current Little Nav Map.  There aren't any pending updates as far as I can tell.  Tried uninstalling and reinstalling both LNM and AI Sleepers.  Still get same results.  I figured it probably wasn't AI Sleepers but just wanted to ask.  I'll see what I can find out from the LNM side of the house.  Thanks.

Share this post


Link to post
Share on other sites
37 minutes ago, FalconAF said:

I checked and I have the current Little Nav Map.  There aren't any pending updates as far as I can tell.  Tried uninstalling and reinstalling both LNM and AI Sleepers.  Still get same results.  I figured it probably wasn't AI Sleepers but just wanted to ask.  I'll see what I can find out from the LNM side of the house.  Thanks.

Hello Rick,

is RemoveSleepers even working?

Where are you flying on the world? Could you try a different location? Or is it everywhere?

Also, look here for an error log, and if there is, please let me know (PM here or email)

C:\Users\...\AppData\Local\Lorby-SI\RemoveAiSleepers

Best regards

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, officercrockey said:

Today he released an update for LNM, which should fix this issue. 

That fixed it.  The first item on his update log was exactly what was happening to me.  The update wasn't available yet when I posted my first post.  Works fine now even with Remove AI Sleepers running. Thanks! 

Edited by FalconAF

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, Lorby_SI said:

is RemoveSleepers even working?

Where are you flying on the world? Could you try a different location? Or is it everywhere?

Also, look here for an error log, and if there is, please let me know (PM here or email)

C:\Users\...\AppData\Local\Lorby-SI\RemoveAiSleepers

Best regards

Remove Sleepers appeared to be working fine even after my P3Dv4.3 update.  Little Navmap just quit working right when I was running Remove Sleepers.  It was not geographic location specific, it was everywhere.

There was no Remove Sleepers error log in the AppData folder.  I'm pretty sure now Remove Sleepers was not the problem.  The very first item in the changelog for the new Little Navmap was (worded something like), "Fixes problem of AI not updating on moving map with some configurations".  My "some configuration" appeared to be when running Remove Sleepers with it after the P3Dv4.3 update.  I can run both Little Navmap and Remove Sleepers together again with no problems. Thanks!

 

Edited by FalconAF

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this