EmpireKicking

fsx.exe has been blocked from accessing Graphics hardware

Recommended Posts

Since Friday the 12th FSX has been playing me up regards my  GPU Drivers or other-wards display. I have read and done unless options regards ways of dealing with this error. Ever since the 12th of October I updated my drivers and that's when it started. I rolled back and uninstalled allot of times then updated and still the same. Before the 12th it was all good and working fine. 

The errors that I get are the following! 
-Display driver nvlddmkm stopped responding and has successfully recovered.
-Application fsx.exe has been blocked from accessing Graphics hardware.

Anyone have any ideas? or anyone have the same error.

End of the day what it's doing top me that when it happens FSX doesn't crash all it does is freeze the display of the game, I still can fly and do the controls and can hear the game sounds just that the display of the game is freeze.

Thanks, Everything is running as admin 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

As stated in the AVSIM CTD Guide, the error belongs to the Nvidia display driver.  Most likely caused when you tried overclocking the video card by changing the Base Clock and Memory Offsets.

Share this post


Link to post
Share on other sites
12 hours ago, Jim Young said:

As stated in the AVSIM CTD Guide, the error belongs to the Nvidia display driver.  Most likely caused when you tried overclocking the video card by changing the Base Clock and Memory Offsets.

Hasn't been touched, But as I was going though each settings I just noticed that that it was running 120hz  and so I adjusted it down to 60hz. NO idea why it went to 120hz since I'm running an 680 card....   even then it's still does it and gives me that error

 

 

Edited by EmpireKicking

Share this post


Link to post
Share on other sites
1 hour ago, Jim Young said:

No more suggestions.

Well, I have changed the Base Clock (-100) and Memory Offsets (-50) even lower then before and this time I got to last for 125mins without crashing 

Share this post


Link to post
Share on other sites

There are posts pinned in this forum regarding the DXGI error and that is because they are making adjustments to the tweaking software from MSI, ASUS, etc., and messing around with the overclock.  They saw where John Doe did it on another site and got out standing performance while running Tomb Raiders or another non-FSX/P3D game.  It doesn't work for flight simulation and you would be best served to stay at the default "tweaks".  FSX/P3D do not use the GPU and the game is based off of the CPU.  A powerful GPU might make for less graphic anomalies but I doubt it even has that capabilities other than running your monitor at 4K or high resolution. 

6 hours ago, EmpireKicking said:

NO idea why it went to 120hz since I'm running an 680 card....   even then it's still does it and gives me that error

Your monitor is what determines the hz, not the video card.  If your monitor is capable of 120 hz (which allows you to run FSX in 3D on your monitor), then that's what you want to set it to and it probably set it there as your video card saw that the monitor was capable of running at 120 hz.  I can assure you that if your monitor was not capable of 120 hz, you would never get the option in the Nvidia settings to raise it to 120 hz.

Best regards,

Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now