Falcon317

GTN 750 and Garmin update process

Recommended Posts

I am new to the GTN 750 and have a basic question about the update process.  I have searched the forum and can't find a direct answer, I apologize if I missed it and am creating duplicate posts.

When I check for updates from inside XPlane 11 via the plugin, does it automatically update both the GTN 750 and the Garmin trainer during the process?

Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

when you do 'check updates....' in sim, what does it say? Then does it offer to download something? And if so, what is downloaded and where?

  • Like 1

Share this post


Link to post
Share on other sites

 

14 minutes ago, RXP said:

Hi,

when you do 'check updates....' in sim, what does it say? Then does it offer to download something? And if so, what is downloaded and where?

Honestly, I have not tried it yet.  I was looking to understand the process in advance and confirm that both the RealityXP 750 and Garmin Trainer will be updated in the same process.  I am currently running 750 version 2.5.7 and Garmin Trainer 6.50.  Normally, what should happen?

Share this post


Link to post
Share on other sites

The best answer is: just try it!

It basically sums up to: it tells you whether there is a new version, it should download the updated installer upon confirming, you then manually run the downloaded installer. It is no different than manually downloading the latest e-commerce installer from our website.

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, RXP said:

The best answer is: just try it!

It basically sums up to: it tells you whether there is a new version, it should download the updated installer upon confirming, you then manually run the downloaded installer. It is no different than manually downloading the latest e-commerce installer from our website.

Okay I will give it a try.  But can you confirm one point please.  When I run the downloaded installer will it also update the Garmin Trainer if needed, as well as the RXP GTN 750, or do I have to update the Garmin Trainer in a separate process?

Thanks!

Share this post


Link to post
Share on other sites

Hi,

The installer auto-detects both the trainer you've already installed and whether there is a new Garmin trainer available, then it will give your best-advise depending on the situation.

Share this post


Link to post
Share on other sites

Hi Jean-Luc,

 

How do I know the version number of both the trainer and the GTN I have installed?

Thanks.

 

Share this post


Link to post
Share on other sites

Hi Alvega,

You might want to just ignore wondering: the installer always installs the latest!

Otherwise, I'd guess running the trainer standalone there must be some sort of "about" with a version number, otherwise, Windows 'uninstall programs' should tell which version is installed.

Our e-commerce installers always show, right below the short description, what their version is and which trainer version they support.

 

Share this post


Link to post
Share on other sites
17 minutes ago, RXP said:

Hi Alvega,

You might want to just ignore wondering: the installer always installs the latest!

Otherwise, I'd guess running the trainer standalone there must be some sort of "about" with a version number, otherwise, Windows 'uninstall programs' should tell which version is installed.

Our e-commerce installers always show, right below the short description, what their version is and which trainer version they support.

 

 

I checked and I have trainer 6.21 and GTN 2.5.2.1. Can I just update the GTN using the X-Plane menu or do I need to update the trainer also?

Thanks.

 

Edited by Alvega

Share this post


Link to post
Share on other sites

The GTN plugin is compatible with trainers v6.21, 6.40, 6.40.1, 6.50 and 6.50.1

I'd strongly suggest updating the trainer because of it's additional capabilities, the VNAV mode, the latest DB (airac 1803) among other things. Last but not least, 6.21 and the others afterward install side-by-side, and you can always use our plugin environment variables to override our plugin from using the most recent trainer and use the older 6.21 instead!

Share this post


Link to post
Share on other sites
1 hour ago, RXP said:

The GTN plugin is compatible with trainers v6.21, 6.40, 6.40.1, 6.50 and 6.50.1

I'd strongly suggest updating the trainer because of it's additional capabilities, the VNAV mode, the latest DB (airac 1803) among other things. Last but not least, 6.21 and the others afterward install side-by-side, and you can always use our plugin environment variables to override our plugin from using the most recent trainer and use the older 6.21 instead!

 

Thanks Jean-Luc, all updated and working.

Cheers.

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now