newtie

(resolved) Enable RXP every time?

Recommended Posts

Hi all-

Got RXP installed in the FSW Falcon and works great, flying right now.

Only one small issue, I get and ‘Enable RXP?’ every time I start P3D 4.4 up

Where is that check box....😀

Thanks,

Mark

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You will need to go to the menu bar\Options\addons and make sure the Reality XP is checked.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Mark,

This most likely is the P3D4 add-on manager asking you to enable our add-on.

I'd guess if it asks you every time, this means P3D4 fails to save your choice in its own settings files. You might want to cross check this P3D4 issue first.

Share this post


Link to post
Share on other sites

Hi-

I'm not having much luck here. P3D4.4 asks me every time if I want to enable RXP and of course I click yes. This only happens with RXP, no other addons.

What is different with RXP? Would installing this outside of P3D Addons fix this?

Thanks,

Mark

 

Share this post


Link to post
Share on other sites
11 minutes ago, newtie said:

Would installing this outside of P3D Addons fix this?

I'd leave it where it is.
Have you tried manually adding the path to your add-ons.cfg in C:\Users\...\AppData\Roaming\Lockheed Martin\Prepar3D v4?
If it's in there check if ACTIVE= is true.

Here's my entry.
[Package.63]
PATH=C:\Users\...\Documents\Prepar3D v4 Add-ons\Reality XP GTN
ACTIVE=true

Here is my add-on.xml. You can compare the contents with yours.

<?xml version="1.0" encoding="UTF-8"?>
<SimBase.Document Type="AddOnXml" version="3,3" id="add-on">
    <AddOn.Name>Reality XP GTN</AddOn.Name>
    <AddOn.Description>Legendary Gauges Redefined</AddOn.Description>
    <AddOn.Component>
        <Category>DLL</Category>
        <Name>Reality XP GTN Menu</Name>
        <Path>C:\Program Files (x86)\Reality XP\GTN Simulation\FltSim\64\rxpGTN_menu.dll</Path>
    </AddOn.Component>
    <AddOn.Component>
        <Category>Gauges</Category>
        <Name>Reality XP GTN Gauge</Name>
        <Path>C:\Program Files (x86)\Reality XP\GTN Simulation\FltSim\64</Path>
    </AddOn.Component>
    <AddOn.Component>
        <Category>Gauges</Category>
        <Name>Reality XP GPS Annunciation</Name>
        <Path>C:\Program Files (x86)\Reality XP\Gauges\GPS Annunciation</Path>
    </AddOn.Component>
</SimBase.Document>

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Bill. I'll look at this shortly.

Share this post


Link to post
Share on other sites

Adding this fixed it Bill...

Path=C:\Users\MarkJ\Documents\Prepar3D v4 Add-ons\Reality XP GTN
Active=TRUE
Required=FALSE

Thanks for the help,

Mark

Share this post


Link to post
Share on other sites

@newtie this still doesn't explain why P3D which is supposed to do this when you enable the add on, is not doing it in the end. Having manually added the entry now, if you disable the Add-on the menus, does it changes this line to false?

Share this post


Link to post
Share on other sites

That is a good question. I will check and let you know.

Thanks!

Mark

Share this post


Link to post
Share on other sites

No. I've been enjoying the fantastic product that you guys have produced and support.

Go away! 😀

Cheers and happy holidays,

Mark

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now