Cruachan

Hesitations at 3 second intervals

Recommended Posts

Hi,

I can hear the collective groans...but wait, this might be something different and unrelated to those phenomena hitherto attributed to long frames, stutters/micro-stutters, pauses/extended pauses.

Ever since updating (Client, Content and Scenery) from 4.3 -> 4.4 I have been aware of barely discernible hesitations occurring at 3 second intervals. When present, these destroy that sensation of fluidity in flight and threaten to compromise that much sought after sense of immersion. 

To date (and this has been observed over many weeks), the appearance of these hesitations seems random but, once they become apparent, persist throughout the rest of a session no matter how the sim is reconfigured.

Interestingly, and perhaps of some significance in providing a pointer as to the likely cause, this issue resolves following a System Restart without any reappearance during a session unless, but not always, the sim has been restarted.

This has been more of an irritant than a show-stopper which is why I have not mentioned it before now.

Currently my procedure is to start the sim in the Raptor at KVPS with my usual Display profile. While in the VC I engage Slew mode and start a slow 360 degree turn. If I see these hesitations then I know I should Restart the System before trying again. If no hesitations are detected than I’m okay to proceed and performance fluidity persists for the rest of that session.

1. Has anyone else encountered this issue?

2. If so, then have you been able to isolate the cause?

Thanks.

Regards,

Mike

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Mike,

Yes, I had this, I deleted everything, aircraft-airports all folders you name it. Installed 4.4 and re-installed everything. painful but I found P3D 4.4 ran a lot better than before.

But also before you do that it well could be an AM. 

I did not post it in the long topic about it, but I found out when I did a full flight the AM 85 really did not work. I spent 5 hours working with task manager open. It was 5 hours well spent, one of many things I found you can have good fps, good texture loading but still get rhythmic "stutters". I found the AM in the end that works on all levels. But it took 5 hours 😞 If you feel 100% it's not an AM then a re-install will give you back a perfect starting place to test. 

I like you did (Client, Content and Scenery) I notice lots of small things there we not right, nothing big. Am glad I went through the pain. 4.4 is a sweet built.

Good luck, hope you find your problem Mike.

Edited by Nyxx
  • Upvote 1

Share this post


Link to post

Yes, I have encountered this "stutter every three seconds" issue......with P3D v4.3. I have only recently installed this, and I suffered from this particular stutter problem at first until I deleted my Prepar3d.cfg file, and contents of the Shaders and SceneryIndexes_x64 folders. This seemed to solve the problem, but I have had to do it another two times since then (although it's possible that I was simply paranoid for one of them). I have since backed up a "good" version of the Prepar3d.cfg file, so that I can simply replace the "stutter inducing" one without having to change all of my settings/controls again.

To be honest, I see more stutters in P3D v4.3 than I did in P3D v3.4....but that may be because more "stuff" is happening/being rendered in the new version. I also still get major stutters at a handful of locations around the UK (which seemed to be caused by loading of AI planes, as disabling all of these seemed to stop this). I would like to think that a graphics card with more VRAM would help here (my GTX 770 only has 2GB), but I really do not have a clue.

Edited by Christopher Low
  • Upvote 1

Share this post


Link to post

Hi David, Chris

Thanks for responding. Perhaps not what I wanted to hear and early on, when these were first noted, I’m sure I tried most, if not all, your suggestions....short of a reinstall, that is. Problem is the sim performs well otherwise when these hesitations are absent and, as always, one is reluctant to upset the status quo needlessly.

Good to know I’m not alone. Chris, it’s interesting you should be attributing this to something in the configuration file. Again, I’m pretty sure I first encountered this after the update had been completed and this would have been with the default configuration and settings in place. However, it’s certainly worth having another go. I did try returning the sim to its default settings without much luck, but that was a while back. I’ll give it another shot.

Edit: This does raise the question as to why performing a System Restart resolves the issue? On the face of, nothing has been changed and yet, quite evidently, something has.

Regards to you both,

Mike

Edited by Cruachan

Share this post


Link to post

The only reason that I deleted the Prepar3d.cfg file in addition to the contents of those two folders is because those were Poppet's instructions in another thread that I discovered when "researching" this problem.

Share this post


Link to post
4 minutes ago, Christopher Low said:

The only reason that I deleted the Prepar3d.cfg file in addition to the contents of those two folders is because those were Poppet's instructions in another thread that I discovered when "researching" this problem.

Hi Chris,

Oh, I confess I hadn’t realised this specific issue had been aired before. This does seem to suggest v4.4 may be responsible in some way as, unlike you, they were not noticed by me in v4.3. Trying to recall whether I performed a full reinstall  when moving up to v4.3. In fact, I’m as near to being certain as I can be that the last fresh full reinstall was when moving to the 64bit Version.

I’m no stranger to stripping the sim back to its default state. It was in such a state until quite recently while testing a couple of 3rd Party products. I did note that while most of the 3rd Party Scenery was disabled I did not encounter any extended pauses...and, consequently, the sim loaded quite rapidly which was great while in testing mode!

Regards,

Mike

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now