misgav

msstdfmt.dll file issue

Recommended Posts

I recenetly installed FSX. I downloaded the free  RC4.3 from the icloud and installed it successfully.

I open up the RC program, choose a flightplan, and hit OK.

This error message appears- please install the MSSTDFMT.dll file.

I searched the web for it, got it and installed in the reccomended location, but still get the same error.

I have windows 10 64bit running on my pc.

Eytan Ornstein

 

Edited by misgav

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You didn't need to search the web, just this forum. Plenty of advice on how to register the DLL.

 

Share this post


Link to post
Share on other sites

OK. I managed to install the dll file and register it.

Here's what happens now. I start fsx, load a flighplan and hit fly now.

I open RC, select flighplan and start.

I go back to fsx. The little rc window is there, haleluyah. Press 1, and the wx cmes on. But nothing happens when I ask for clearance.

Weirdest thing, I can hear clearance control interacting with other planes near me!

Go back to the RC window and the dreaded error75 rcfsuipc.rc4code appears and RC shuts down.

I tried running  RC as adminstrator, but in windows 10 when I do that, I'm asked to reenter the licence code (which I don't have anymore as RC4.3 is installed and running)

So what now?

Eytan

Share this post


Link to post
Share on other sites

Just a small correction to my previous post.

The ATC I heard was the default FSX running in the backgound, not RC.

Eytan

Share this post


Link to post
Share on other sites

Eytan,

Firstly, you don't need to load a flight plan into FSX. Just load it into RC4.

You need to reduce the volume of ATC to zero in FSX. Don't disable it, just reduce the volume to zero.

Error 75 is path/file access error. The location of your plans need to allow RC4 to write to it. Make sure it has write access.

Share this post


Link to post
Share on other sites

Hi

I'm not that computer savvy.

How do I ensure RC4 has write access?

Eytan

Share this post


Link to post
Share on other sites

Right-click the folder and choose Properties. Ensure the Read-only option is unchecked.

Also, on the sharing tab ensure you have Full Control for your user.

To be honest if you're using standard Windows folders and RC4 is on the same PC all of this should be okay.

If you can create a new text file where your plans are and then enter some data and save it then you have full access. The problem is elsewhere.

Edited by Ray Proudfoot

Share this post


Link to post
Share on other sites

I notice I have two RC folders- rcv4, and rcv4x.

When I want to do what you said for rcv4, I get a window saying- do you want to apply this to this folder or...to all subfolders... etc?

As to the rcv4x, the unsetting of read only went smoothly.

Eytan

Share this post


Link to post
Share on other sites

Why do you have two installs of RC4? Delete one of those folders.

Responding 'Yes' is standard reply when applying permissions.

Share this post


Link to post
Share on other sites

Ray,

2 folders seems to be the norm. I have RCv4 and RCv4x. RC4 just contains Internet links and what seems to be uninstall info. RC4x is the operational one.

But you are correct, RCv4 can be deleted without harm.

 

Share this post


Link to post
Share on other sites

Thanks Ian. It’s been a few years since I last installed RC4. I did wonder if it related to dual installs - one for FSX and the other for P3D.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now