jcourtney

GTN 750 in FSX RNAV approach not intercepting glide slope

Recommended Posts

I just purchased the GTN750 and installed it into the default learjet aircraft.  I've tried multiple different RNAV LPV approaches KCMH was one of them and with flaps and gear down and approach activated, the system will not intercept and follow the glide slope.  I've double-checked all the of the settings (right-click on panel) and setup as suggested in another topic.  The approach automatically switches autopilot to APP and turns off altitude hold.  Does anybody know why this would not be working?  The glide slope is shown on the display, but does not get followed like on ILS.  It seems there are other complaints about this but I have not found a resolution.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Ok, I've played around with this for a little while and seem to have gotten it to work.  I also discovered an issue with the ILS and a similar procedure of button pushes fixes the RNAV not intercepting the glide slope problem too.  Once the GTN750 switches to approach APP automatically, you need to turn the altitude hold ALT back on and descend yourself to the next waypoint.  Once the glide slope indicator starts to come alive and move, press the APP switch twice.  The autopilot will do a brief turn right then engage the glide slope.  I thought there was a way to tell the GTN to not switch into APP mode automatically, but I have not found this setting yet.  Anyway the above works for now until someone might post a more correct procedure to follow.

Share this post


Link to post
Share on other sites


Hi,

Does it look like a Learjet A/P specific limitation somehow?

As for the automatic APPR mode: open the Configuration Panel and look in the AFMS settings.

Share this post


Link to post
Share on other sites
28 minutes ago, jcourtney said:

No, this was a problem in the Baron too.

Default Baron?

Share this post


Link to post
Share on other sites
Posted (edited)

I've noticed a similar issue in the A2A Bonanza.  My RNAV glide paths don't capture and the APPR & CPLD indicators on the autopilot annunciator panel flash rapidly and eventually extinguish.  So far all the ILS approaches I've attempted have worked great, however.

Here's a video demonstrating what I'm seeing.  Maybe that will help?

Edit:  Actually in the video I linked, it looks like the glide path captured, but the approach course did not.  Either way, this happens on all my flights except on ILS approaches.

Edited by Clorix

Share this post


Link to post
Share on other sites

Hi,

v2.5.14 is now released and should fix this issue.

Share this post


Link to post
Share on other sites
Posted (edited)

v2.5.15 is current.  It does fix the issue.

Ha! Saying that felt like ATC calling out a new ATIS report.

Flew a three + hour flight today into marginal IFR conditions and was great to rely on the RXP GTN 750 for guidance. 

Edited by fppilot
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now